6

Just bought a 'Canoscan Lide 120' scanner that I plan to use on a windows 7 laptop. In Ubuntu 14.04 64-bit it is detected by 'sane-find-scanner' but with 'Simple Scan' I just get: "No scanners detected". Any hope???

5
  • Here's a lead you could check out: hamrick.com/vuescan/canon_lide_120.html
    – Marc
    Nov 9, 2014 at 3:42
  • @Marc: that driver doesn't have Linux support (yet). Feb 8, 2015 at 19:44
  • 1
    It seems that the SANE driver might be working now. It is in the Untested state (here). Note that the Lide 220, which has a higher resolution and one more button has the driver in the Complete state. Jun 3, 2015 at 21:05
  • @jorcas, do you have any update on this? Is the scanner now working as suggested by Walter Tross?
    – versvs
    Aug 26, 2015 at 8:51
  • 1
    more accurate answer in askubuntu.com/questions/652769/…
    – user528934
    May 11, 2016 at 16:12

1 Answer 1

3

Now the canon LiDE 120 runs on Ubuntu 14.04 and even tested in 16.04 as well, for this you have to do the following:

To add the SANE PPA so that you have the latest version of SANE (backport), open your terminal and type

$ sudo add-apt-repository ppa:rolfbensch/sane-git

then run

$ sudo apt update

then run

$ sudo apt full-upgrade

Or if you do not have sane and all its libraries installed then install it by executing the following.

$ sudo apt -y install sane libsane libsane-common sane-utils libsane-extras

you can also use synaptic package manager to check and make sure that sane is up-to-date with all necessary libraries.

Now your scanner should work with any frontends like simple-scan or gscan2pdf.

or you can compile sane-backend from the latest source, that will also do the job, in that case you have to have libusb-dev build-essential libsane-dev and for avahi network support libavahi-client-dev libavahi-glib-dev installed on your system. To do the compiling, you can follow https://help.ubuntu.com/community/CompileSaneFromSource and it will help you some more https://help.ubuntu.com/community/sane

5
  • Unfortunately, this installs, but doesn't fix the issue with the scanner. Apparently detecting the LiDE120 isn't hard, but it uses a newer controller chip which isn't yet fully supported by XSANE. Using the latest source, I get nothing but full black pages, and some bad noise from the motor (XSane killed my previous LiDE scanner too, I suspect). You can remove the above installed software via: sudo apt-get install ppa-purge, and sudo ppa-purge ppa:rolfbensch/sane-git. Thanks for the advice anyways.
    – Cloud
    Oct 23, 2016 at 0:37
  • @DevNull, what Ubuntu release you are using? That PPA supports up to Xenial, for further query, you need to contact the SANE (Scanner Access Now Easy - A unified project to add support for scanners to all Linux varients) developer Rolf Bensch directly. Have you tried "Simple Scan" or gscan2pdf tool to scan it? What is the result of sudo dpkg -l libsane and sudo scanimage -V after activating that PPA or after compiling the backend from the latest source? Oct 23, 2016 at 16:10
  • I tried with Ubuntu 16.04.1 x64 (LTS), on kernel 4.4.0-45-generic. Everything is up-to-date with apt. I tried with the commands noted above after installing the custom PPA (even rebooted), and no joy.
    – Cloud
    Oct 24, 2016 at 16:50
  • @DevNull I am using the device Canon LiDE 120 right now with 16.04.1 with "Simple Scan" tool as front-end with the help of that PPA and here are some success reports and special cases you'll find answers.launchpad.net/ubuntu/+question/262320 :) Oct 26, 2016 at 3:47
  • Thank you for that information. I will re-test this tomorrow. :)
    – Cloud
    Oct 26, 2016 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.