2

I formatted my flash drive with GParted and gave it a 32GB FAT32 filesystem. Now, I can only write to it as root! I have tried running the command sudo chown $USER:$USER -R /media/usb0/, but I get an Operation not permitted error, which is weird because I ran that command as root. ls -la /media/usb0/ gives

total 20
drwxr-xr-x 2 root root 16384 Dec 31  1969 .
drwxr-xr-x 6 root root  4096 Nov  8 08:22 ..

sudo fdisk -l /dev/sdb1 gives Disk /dev/sdb1: 29.8 GiB, 32004636672 bytes, 62509056 sectors Units: sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disklabel type: dos Disk identifier: 0x0009e87d

Device Boot Start End Sectors Size Id Type /dev/sdb1p1 ? 3223366752 3470046675 246679924 117.6G f4 SpeedStor /dev/sdb1p2 ? 378192737 710426324 332233588 158.4G 10 OPUS /dev/sdb1p3 ? 225603442 225603451 10 5K 74 unknown

Partition table entries are not in disk order.

cat /etc/fstab gives /etc/fstab: static file system information. Use 'blkid' to print the universally unique identifier for a

device; this may be used with UUID= as a more robust way to name devices

that works even if disks are added and removed. See fstab(5).

#

/ was on /dev/sda1 during installation

UUID=f4b26011-2e69-4f2f-94c5-151e750d615d / ext4 errors=remount-ro 0 1

swap was on /dev/sda5 during installation

UUID=4dfce2fd-fad5-4aaa-bebe-bc8500b6f3e6 none swap sw 0 0 /dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0 /dev/sr1 /media/cdrom1 udf,iso9660 user,noauto 0 0 /dev/sdb1 /media/usb0 auto rw,user,noauto 0 0

  • I have also tried deleting /media/usb0 (the mount point) and rebooting, but it just creates it again with the same root ownership. – John Scott Nov 8 '14 at 18:19
  • Can I just repartition the whole thing without having to be root? – John Scott Nov 8 '14 at 19:16
  • What does ls -la /media/usb0/ say? – Karl Richter Nov 8 '14 at 19:26
  • 1
    Check the following link especially the adjustments for FAT16/32 FS.. askubuntu.com/a/14872/216503 – heemayl Nov 8 '14 at 19:58
  • @KarlRichter ls -la /media/usb0/ says: total 20 drwxr-xr-x 2 root root 16384 Dec 31 1969 . drwxr-xr-x 6 root root 4096 Nov 8 08:22 .. – John Scott Nov 8 '14 at 20:02
1
+50

According to the documentation:

Interfering services

It might happen, that two services/programs responsible for automounting might interfere and 
thereby prevent a successful automount and permission setting. Example: Activating the Automount
function of Nautilus while using pmount will result read only permissions for normal users. 
Either disable Nautilus' Automount function or deinstall pmount. 

If you have package pmount installed try removing it.

  • I don't have pmount installed. – John Scott Nov 14 '14 at 22:02
  • Although you were not the one who solved my problem (I solved it myself), I have decided to give you the bounty because I thought removing pmount would be a great solution for others that are having this problem. I also don't like seeing a bounty go to waste because I can't give it to myself or take it back. – John Scott Nov 15 '14 at 14:39
0

I realize I made this question, but I thought I would post my solution. I just opened up /etc/fstab, deleted the line about my flash drive, plugged it in, and it worked!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.