I know similar questions have been asked in the forum in the past, but I cannot get the exact answer I need: hence, resorting to a new question.

A month ago, my system with r1869 driver module worked properly without any problems. However, now, it doesn't - no network connectivity on eth0 (wired). I solved this by the normal method of going to the Realtek website and installing their module (r8168). Now the system works normal again.

I am sure I had some or the other change which triggered the behaviour but cannot, for the life of me, remember what was the change.

My question is this - what could have possibly caused the r8169 module to stop working? Kernel updates? Any recent Ubuntu patches? (though I do not install any updates as I want stability on a working setup)

PS: Title may be misleading - please suggest a more appropriate one if you do have time.

  • Ping for attention (suggestions to improve the qn atleast) Dont want to start a bounty for silly qns just to attract attention... – L__ Nov 17 '14 at 4:56

Did you change any else drivers before it started glitch? r8169 has serious uncompabilities with NVIDIA that I am trying to resolve. Always I change my video driver from Noveau to NVIDIA binary driver 331.89, my r8169 makes internet very slow. As I am child and parents don't allow(once I broke my OS trying to install r8168), I can't install r8168. But that is usually needed to fix problems with Realtek RTL8111/8168 Ethernet Cards...

  • No other drivers... However r8168 is working fine and i have no problems. Hence marking this as answered. – L__ Dec 8 '14 at 4:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.