-2

I have installed Ubuntu 12.04 on Acer travelMate 4060, with Ubuntu cd. I have no wired connection. Any help will be appreciated.

$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:c0:9f:d0:20:c4  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:16 Base address:0x2000 

eth1      Link encap:Ethernet  HWaddr 00:13:ce:1f:63:e7  
          inet addr:192.168.1.107  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::213:ceff:fe1f:63e7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3845 errors:6 dropped:6 overruns:0 frame:0
          TX packets:3646 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2025536 (2.0 MB)  TX bytes:604176 (604.1 KB)
          Interrupt:17 Base address:0xe000 Memory:b0101000-b0101fff 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:794 errors:0 dropped:0 overruns:0 frame:0
          TX packets:794 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:83138 (83.1 KB)  TX bytes:83138 (83.1 KB)

     $ dmesg |grep -e eth0 -e 8139
        [    0.220818] pci 0000:06:08.0: [10ec:8139] type 0 class 0x000200
        [   17.559627] 8139too: 8139too Fast Ethernet driver 0.9.28
        [   17.559692] 8139too 0000:06:08.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
        [   17.560984] 8139too 0000:06:08.0: eth0: RealTek RTL8139 at 0x2000, 00:c0:9f:d0:20:c4, IRQ 16
        [   20.354277] 8139too 0000:06:08.0: eth0: link down
        [   20.354781] ADDRCONF(NETDEV_UP): eth0: link is not ready
        [   20.360468] ADDRCONF(NETDEV_UP): eth0: link is not ready

rfkill list all gives:

0: phy0: Wireless LAN
Soft blocked: no 
Hard blocked: no 

I have tried sudo modprobe 8139too with no results.

  • It could be that your ethernet driver is either not installed or not loaded. – Mario Kamenjak Nov 8 '14 at 0:33
  • 1
    Check your router, check your configuration, check your drivers, check your hardware, and after you've put some amount of effort into attempting to solve the problem, come back here and post relevant information. As it stands there is no way to tell what the problem could be based on the information you've posted here. – Jason C Nov 8 '14 at 0:49
  • What is the output of rfkill list all? – Seth Nov 8 '14 at 1:09
  • Looks like we might need dmesg | grep -e eth -e 8139 as well. – Seth Nov 8 '14 at 1:12
  • Hi Seth, rfkill list all gives: rfkill list all 0: phy0: Wireless LAN Soft blocked: no Hard blocked: no – GEORGE Nov 9 '14 at 2:50
1

Please connect the ethernet and open a terminal and do:

sudo modprobe 8139too

If your connection comes to life, let's get the driver to load automatically on boot:

sudo -i
echo 8139too  >>  /etc/modules
exit

After you load the driver, is an interface created, ideally eth0?

ifconfig

Are there any clues in the message logs?

dmesg | grep -e eth0 -e 8139

Let's do some additional tests. Please open a terminal and run:

cat /etc/network/interfaces  > ethernet.txt
cat /etc/NetworkManager/NetworkManager.conf  >>  ethernet.txt
dmesg | grep eth0  >>  ethernet.txt
nm-tool  >>  ethernet.txt

Find the file ethernet.txt in your user directory and copy and paste it here: http://paste.ubuntu.com. Give us the link in your reply.

I notice your /etc/NetworkManager/NetworkManager.conf file contains:

no-auto-default=00:C0:9F:D0:20:C4,

According to the manpage: http://manpages.ubuntu.com/manpages/utopic/man5/NetworkManager.conf.5.html

List a device in this option to inhibit creating the default connection for the device.

Let's do two things to correct this. First:

sudo gedit /etc/NetworkManager/NetworkManager.conf

Use nano or kate or leafpad if you don't have the text editor gedit. Remove the line I referenced above. Proofread carefully, save and close the text editor.

Second, click the Network Manager icon and select 'Edit Connections.' Select the Wired Connection and click 'Edit.' Select the General tab and check the box for 'Automatically connect when available...' Save and close. Now does it connect?

| improve this answer | |
  • Hi Chili555, I have tried sudo modprobe 8139too with no results could it be wireless driver: description: Wireless interface product: PRO/Wireless 2200BG [Calexico2] Network Connection taking over the priority???? Thanks for any help – GEORGE Nov 9 '14 at 2:38
  • Network Manager is supposed to give priority to the more secure ethernet. Please see my edit in a few moments. – chili555 Nov 9 '14 at 2:45
  • ifconfig eth0. ifconfig eth0 Link encap:Ethernet HWaddr 00:c0:9f:d0:20:c4 UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) Interrupt:16 Base address:0x2000 eth1 Link encap:Ethernet HWaddr 00:13:ce:1f:63:e7 inet addr:192.168.1.107 Bcast:192.168.1.255 Askubuntu wouldn't let me post more of results. sure i'm not familiar with postin – GEORGE Nov 9 '14 at 5:07
  • ifconfig eth0. ifconfig eth0 Link encap:Ethernet HWaddr 00:c0:9f:d0:20:c4 UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) Interrupt:16 Base address:0x2000 eth1 Link encap:Ethernet HWaddr 00:13:ce:1f:63:e7 inet addr:192.168.1.107 Bcast:192.168.1.255 Mask:255.25 – GEORGE Nov 9 '14 at 5:07
  • Please see my edit above. – chili555 Nov 10 '14 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.