7

I have a new Acer Aspire E13 (ES1-311-P1D5) notebook. I tried to install Ubuntu 14.10 with disabled Secure Boot but enabled UEFI. After the installation I couldn't bot. I just got "No Bootable Device". I'm not sure what to do except for diabling UEFI.

Is there any way or anything that I need to consider?

-1

Could try this similar issue: http://ubuntuforums.org/showthread.php?t=2237568

3
  • I'll give it a try. Do you have Secure Boot enabled?
    – user346585
    Nov 7 '14 at 18:37
  • 5
    You should write a proper answer instead of just giving a link to an external site. What if the ext link goes down?
    – astrob0t
    Nov 7 '14 at 18:44
  • I activated SecureBoot, added grubx64.efi in my BIOS settings and it works. Thanks!
    – user346585
    Nov 8 '14 at 8:09
6

In my case some UEFI params needed to be set in the BIOS. I followed these instructions:

https://itsfoss.com/no-bootable-device-found-ubuntu/

Here is a short description of the steps.

Step 1: Go to BIOS (with F2)

Step 2: Turn ON Secure Boot (You might need to set BIOS password before doing this)

Step 3: Select an UEFI file as trusted for executing: HDD0 -> EFI -> ubuntu -> shimx64.efi

Step 4: Add a description and confirm. Save BIOS settings and reboot.

BTW, later I discovered that when Secure Boot is turned ON that Linux won't recognize WiFi hardware, so I needed to turn it OFF.

4
  • Please be detailed. You may quote other sources but mere posting of links is not good enough. What if the link goes down. You should add the link as a source instead, Have a great day ahead. Jun 27 '16 at 12:38
  • 1
    @SharadGautam The description has been updated with steps. BTW have used the procedure several times in last couple of days
    – ssasa
    Jul 6 '16 at 16:16
  • Saved my hair on an Acer Aspire E 11 :-)
    – Marcus
    Aug 31 '16 at 19:24
  • How do you select a UEFI file? Apr 6 '17 at 10:26
0

I have a acer aspire E 15 - E5-573: After trying different times different bios configurations, ended installing Ubuntu studio 15.04, note version i386 not amd64, with ethernet connection and the bios set to - Legacy. Ubuntu studio immediatly after disk load made the upgrade to version 16.04.

Another important thing is to check the bios version, if it is 1.25 I read somewhere that it has a bug that doesn´t lets install Linux. Well I installed windows 10 to make a bios update to version 1.37. Then made those bios tests until - bios: Legacy, iso: i386 not amd64.

Good luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy