I am running Ubuntu Desktop 14.04 on a desktop PC with a Nvidia GTX 660 connected to a HP LP2475w 24" monitor over DisplayPort.

It boots up fine, but if I switch off the monitor and switch it on again (for example at night) Ubuntu does not recognize the monitor at switch-on. Screen remains black, and the only way out is to reboot.

This is particularly annoying as I can and do switch the monitor to a different machine and back again, and the same thing happens. I have to reboot the Ubuntu machine to get the display back. Windows 8.1 manages this without an issue.

If I connect over DVI there is no problem; however, when I change to a 4K monitor I will need to use DP. Please help!


UPDATE

If I have a second monitor connected using DVI, I still loose the DisplayPort monitor if I switch it off and on again, but I am able to recover it by using Ctrl-Alt-F1 and then Ctrl-Alt-F7.

If the DisplayPort monitor is connected on its own, this method does not help. This is still a serious issue for me.

I can't believe no-one else is having it. Anyone care to share any experiences?

Do different graphics cards work better? Different monitors?

  • 1
    If I have a second monitor connected using DVI, I still loose the DisplayPort monitor if I switch it off and on again, but I am able to recover it by using Ctrl-Alt-F1 and then Ctrl-Alt-F7. If the DisplayPort monitor is connected on its own, this method does not help. This is still a serious issue for me. I can't believe no-one else is having it. Anyone care to share any experiences? Do different graphics cards work better? Different monitors? – johnr Nov 26 '14 at 16:04
  • 1
    Thanks David, you're right. This is the same issue. Nice to know I'm not going mad! – johnr Jan 14 '15 at 7:59
  • Yes, screen saver does work - that was how I fist came across the issue. Display would just die if left for too long, and not come back. – johnr Jan 17 '15 at 15:13
  • My issue was: If I use monitor's screen saver timer, screen turns 'off' and is non-recoverable. If I use Ubuntu's (software) screen saver, then screen backlight stays ON. What happens for you? – david6 Jan 17 '15 at 15:46
  • Oh I see. Yes, my behaviour is the same as yours. If the backlight stays on it is recoverable. The issue is only if the monitor powers off or is switched to a different input that it is unrecoverable. – johnr Jan 18 '15 at 10:52

I just had the same problem with a Dell u2913wm connected to a i5-5775c Iris Pro 6200 via Displayport. When I switched inputs on the monitor, it would not display an image afterwards.

The problem could be solved by using ssh to log into the machine and running:

env DISPLAY=:0 xset dpms force off
env DISPLAY=:0 xset dpms force on

While not very practical, that would turn the screen back on.

After reading the answer that mentioned turning off DDC/CI, I fiddled with my monitor settings since manually setting dpms off and on is too cumbersome. DDC/CI setting did nothing for me, but my monitor had an additional Displayport 1.2 setting that was disabled.

After switching the Displayport 1.2 setting to enabled, my monitor started working again after changing inputs, or turning it off, just as it is supposed to.

  • This works great. To avoid doing SSH, a solution is to create a shell script with the commands you have shown. Then create in Settings / Keyboard / Shortcuts a custom shortcut to than command when Ctrl+Alt+W is pressed (or any other combination not yet used) – coderazzi May 1 '17 at 19:58
  • @coderazzi that will not work when the desktop is locked – Edheldil May 26 '17 at 14:58
  • @Edheldil: you are right. Normally, I have to enter first blindly the password, which unlocks the desktop. Then, press the shortcut. – coderazzi Nov 18 '17 at 21:14

I have this same issue. However, my screen also wont sleep. So any workaround (eg. turning screen on/off) hits this issue.

This bug has been raised on LaunchPad:

launchpad >> bug 1313539

However, it is currently marked as a duplicate of a more generic bug:

launchpad >> bug 1308105 (still open)


UPDATE: Jan-17

I just tried with a DVI Dual-Link cable.

Unfortunately my video card does not support Dual-Link, only Single-Link. However, to the best of my knowledge the HP DL139A ('DMS-59 to DVI Dual-head Y-Cable') does. (Anyone else know?)

No issues (screen saver, screen sleep, or wakeup) under DVI, except drops to 1920x1200 resolution. Inconclusive, but issue is NOT present with same 27" screen, and identical OS / driver setup.


UPDATE: Jan-19

New (bigger/faster) video card still on order.

Tried with another video card, with dual DisplayPort (instead of DMS-59).

Unfortunately the HP adapter (HP P/N 481409-220, included) is only DisplayPort to DVI Single-Link. They have another adapter (HP P/N NR078AA) that does DisplayPort to DVI Dual-Link, but it costs USD $150 (a rip off).

No issues (screen saver/screen sleep, or wakeup) under DVI, except drops to 1920x1200 resolution. Direct DisplayPort cable (from this card) still has same issues.


UPDATE: Feb-12

Resolved for now, by moving screen close to PC and using (Samsung supplied) DVI Dual-Link cable that came with monitor.

Still unable to use properly with DisplayPort cable.

I had the same issues. I connect my Windows 7 PC to my Dell 2709W monitor by DisplayPort. (Nvidia GTX 750)

I found solutions here: https://superuser.com/questions/630555/

I disabled the "DDC/CI" in my monitor setting. This solved the problem. I hope this helps.

  • 1
    Thanks for your input. Although your issue is related, it is a bit different to mine. I have seen this issue described on Win7. I am running Ubuntu desktop and I have to reboot when the monitor powers off (even due to a timeout). I have disabled DDC/CI and it makes no difference in my case. This is still a big problem for me. Does anyone have any similar Ubuntu experience? – johnr Jan 10 '15 at 15:19
  • Solved the problem for me, using Xubuntu (unfortunately not all monitors have this setting). – luator Aug 12 '15 at 8:35

I had the same issue with my ASUS laptop and Dell monitor. What I end up doing is to use xset dpms force off command to make monitor go into power saving mode, instead of turning the monitor off with its power button. I can wake up the screen by pressing a key on keyboard or moving the mouse. With this method to turn off the screen, I never run into the issue of having a black screen when I turn on the screen again. I also made a monitorOff.desktop in /usr/share/applications and pin it to launcher, so I can just click on the icon to turn off the monitor.

I ran into something similar on a 4-Monitor configuration connected via DisplayPort to a NVidia GK107 [NVS 510] running under KUbuntu 14.04

Whenever one of the Displays is being disabled, the other Displays will randomly rearrange their positions. When switching the Display back on this does not bring the old configuration back.

Just recently I noticed a memory leak with SSH and KDE Bug 280381.

Harshly just killing the kde4d (since I needed that memory) I noticed afterwards that the display setting stays the same. I have been able to reproduce that behavior, so I think that the problem may lie somewhere with kded4.

Update:

Since I don't think that killing the whole kded4 process is a valid option, I dug a little into the Services and found that disabling the KScreen2 Service (System Settings > Startup and Shutdown > Service Manager) solves the problem.

I too had an issue similar to this in 14.04 with a monitor not waking up while connected to the displayport. After investigating it, it didn't seem to be an issue with the monitor.

What seems to be working for me(last 24hrs) is the downgrade of xfce-settings as suggested in this bug report, posting #7

https://bugs.launchpad.net/ubuntu/+bug/1313539

apt-get couldn't find the downgraded package for saucy.

I found it on launchpad.

Installed it via:

sudo dpkg -i xfce4-settings_4.11.0-1ubuntu1_amd64.deb 

Confirmed it installed via:

xfce4-settings-manager -V

I can now have my monitor go to sleep and it seems to be waking up as expected.

My solution to this was making an xbindkeys hotkey (Win+M, but you might want another one) to run the following command:

xrandr --output DP2 --mode 3840x2160

This command will restore the video mode of the monitor when you run it. mode parameter here is the native resolution of my monitor, which is normally automatically chosen on boot-up when the monitor is on. You can determine the name and resolution of your output if you simply run xrandr without arguments.

Now, if I press power button on the monitor to turn it off, and then press it again to turn it back on, I can simply type my Win+M hotkey, and the image is back on the screen.

protected by Byte Commander Mar 18 '16 at 8:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.