13

Quite simply, how do I setup, configure and use the Sony DUALSHOCK 4 controller with Ubuntu 14.10 ("Utopic Unicorn")?

I remember the Linux kernel was updated a while back to add native support... Does this mean I should be able to simply pair it by bluetooth (from the notification area) and off I go?

Or is there more to it than this?

I tried to follow these instructions: https://askubuntu.com/a/450091/230107

But when I type sudo pip install ds4drv, I am told sudo: pip: command not found.

25

Okay, all one needs to do is "pair" the controller just like any other bluetooth device (these instructions relate to the "regular" variant of Ubuntu LTS - adjust them accordingly if you use a different variant of Ubuntu or a different Linux-based operating system)...

  • Hold the PlayStation logo and Share buttons to put the controller into "pairing" mode (the Light Bar/LED should start to rapidly blink/flash), then pair the controller with the computer using the bluetooth settings (Show Applications → Settings → Bluetooth → Wireless Controller or bluetooth icon (at the top-right of the screen) → bluetooth icon (in sub-menu) → Bluetooth Settings → Wireless Controller).

Once the controller is "paired", you can turn it on by pressing (not holding!) the PlayStation logo button - do this before opening Steam or a game, because sometimes they may not recognize the controller if you do this after opening Steam or a game.

Ubuntu LTS 18.04 and newer has pseudo-official support for the DUALSHOCK 4 (it correctly recognizes the DUALSHOCK 4 as a controller) and Valve Software's Steam has native/official support... Ubuntu LTS doesn't offer anything in the way of configuration for controllers, but Steam has a default setup available or you can configure the controller to your individual liking - to do this, go into "Big Picture Mode" and adjust the "Controller" settings.

A few points about what I have noticed however...

  • Steam has surprisingly good support for the DUALSHOCK 4 and even many older games seem to work well enough... Many games available outside of Steam also seem to work well (such as those from GOG.com) - but it varies from game-to-game, so you'll need to experiment yourself.
  • If you're using "Big Picture Mode" and you have configured your controller in Steam, it will show a green "controller" icon for games which support the DUALSHOCK 4.
  • Steam will work its magic to get the DUALSHOCK 4 working as expected in most games (e.g. PlayStation X for "select"/"accept"/"enter" and PlayStation O for "cancel"/"decline"/"back"), however some games will still show Microsoft Xbox series icons, which may lead to some minor confusion.
  • Some games (including numerous older games) support force-feedback (vibration), though this varies and you may need to enable this functionality within the game itself.
  • Support for the "fancy" functionality of the DUALSHOCK 4 - such as accelerometer control and the touchpad - may not work in part or at all... I found a couple of games in Steam that supported the accelerometer (older games, too!), but support seems to be pretty mixed from game-to-game.
  • There is no way to tell how much battery is remaining on the DUALSHOCK 4... You will just need to wait until it runs flat (not recommended, as this is not the best way to care for Lithium batteries) or make an educated guess and put it on-charge every so often.
  • You will need to manually turn the controller off when you're finished with it, by holding the PlayStation logo button until it switches off (you should see the Light Bar/LED turn off).

Updated content of answer to reflect experience using Ubuntu LTS 18.04 ("Bionic Beaver") and the most recent version of Steam as at September 8th, 2018.

  • 3
    Is there anything else that needs to be done? I paired the PS4 controller just like you said but when I press the home button the controller will not stay on. – Reya276 Dec 18 '14 at 2:37
  • That's all I did and it worked fine - are you using Ubuntu 14.10 or higher? Native support for the DUALSHOCK 4 was introduced with version 3.15 of the Linux kernel, which first made its debut in Ubuntu 14.10... – Gregory Opera Jan 19 '15 at 9:19
  • This worked for me in Ubuntu 14.10, but my experience in 15.04 is Reya's: It pairs properly, but won't stay connected for more than 5 seconds. It works properly when wired, with Steam in Ubuntu, and works with a simple Bluetooth connection, or wired in Windows 8.1. – Turtles Are Cute May 3 '15 at 6:16
0

You need to install python-pip to use pip.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.