I tried to get vlc 2.2, so that I could run vlsub. In terminal, I entered sudo add-apt-repository ppa:videolan/master-daily followed by sudo apt-get update and then sudo apt-get install vlc.

VLC appears in my dock and in applications, but it cannot open now.

What is the problem? Did I add updates from the repository that I shouldn't have? How can I close it and revert back to my older version of VLC?

  • what happens when you run in a terminal vlc? Nov 7, 2014 at 11:53
  • Terminal outputs the following: VLC media player 2.1.4 Rincewind (revision 2.1.4-0-g2a072be) vlc: symbol lookup error: /usr/lib/libvlc.so.5: undefined symbol: pl_Get
    – Push
    Nov 7, 2014 at 12:04
  • does this help askubuntu.com/questions/503860/… ? Nov 7, 2014 at 13:49
  • I have another problem now with VLC. The software center did an automatic upgrade to packages, and deleted VLC from my entire system. Now I cannot download it. When I try downloading in Terminal with the command sudo apt-get install vlc-nox, it outputs: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
    – Push
    Nov 12, 2014 at 2:13
  • It follows with: The following information may help resolve the situation: The following packages have unmet dependencies: vlc-nox : Depends : libavcodec55 (>= 6:9.1-1) but it is not installable or libavcodec-extra-55 (>= 6:10~~git20131218.b3189af~ubuntu14.04.1) but it is not installable
    – Push
    Nov 12, 2014 at 2:16

1 Answer 1


Yay, I fixed it on my own! I just removed the repository I added above and updated with the commands: sudo rm /etc/apt/sources.list.d/videolan-* && sudo apt-get update .

  • Awesome, feel free to mark your answer as thee answer :). Dec 31, 2015 at 12:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .