A similar question was asked, here: Subtitle are not working in vlc

But I have tried all the fixes, and none of them work for me. I am trying to use Chinese subtitles from OpenSubtitles. I get a series of square boxes. When opening the .srt file in text editor, I can read the Chinese. I have copied and pasted into another text file with .srt extension. No good. I've tried every encoding that looks like it makes sense in Vlc. I've also tried the bug fix that Arie Skliarouk suggested, but nothing works. Any tips?

  • I realized VLC has an addon called VLsub 0.9.10. VLC tells me to open a movie, then click on that, and choose the language of the subs I want it to download. But when I click on it, nothing happens. Bug?
    – Push
    Nov 7, 2014 at 9:56
  • Seems that nobody is reading this one, but I have an update and a new problem. I am now using VLC 2.2.0-rc1 Weatherwax. In View, there is a setting called "Download Subtitles." How to use this feature is pretty self-explanatory. However, every time I click Search by Hash, nothing happens. Nothing happens for Search by Name either. No subtitles appear for download. Has anybody else experienced this, or know how to fix it?
    – Push
    Nov 12, 2014 at 4:54
  • Have just found your question, having the same problem here, Ubuntu 14.04, VLC 2.1.6: square boxes. I open the subtitle (from opensubtitle.org) on LibreOffice and it shows fine with SimSun font. The 'file' command says it's a UTF-8 Unicode (with BOM), VLC is on UTF-8, SimSun, but only shows little squares. Bug?
    – Rodrigo
    Aug 27, 2015 at 0:45
  • This solution worked for me: askubuntu.com/a/18731/416671 try to copy the contents of the file to a new one.
    – Rodrigo
    Aug 27, 2015 at 0:59


You must log in to answer this question.

Browse other questions tagged .