27

I am currently using Ubuntu 14.10. Steam is showing up in the Ubuntu Software Center, but when I click on it it says:

Not found
There isn't a software package called "steam" in your current software sources.

enter image description here

Is there a fix for this? Am I the only one having this problem?

  • 1
    Get the Steam package from the official website. Here's a link: http://store.steampowered.com/about/. If you meet any error do sudo apt-get -f install to install dependencies. – dat tutbrus Nov 4 '15 at 11:17
34

First Update the system. Then try with commandline as follows:

sudo apt-get update && sudo apt-get install steam
|improve this answer|||||
  • 4
    E: Unable to locate package steam – alvas Aug 20 '15 at 11:35
  • 1
    -1 the package was removed in 14.10 – Thorbjørn Ravn Andersen Oct 27 '15 at 9:47
  • 4
    +1 It appears that it has been readded in 15.10. – Aracthor Oct 28 '15 at 13:13
  • This answer only works for Ubuntu 32-bit. Steam is part of the "multiverse" repository, but only the 32-bit version. If you have use 64-bit, check the other answers. – That Brazilian Guy May 26 '16 at 16:14
10

IMG:  Steam can be install as a flatpak package in all currently supported versions of Ubuntu. Open the terminal and type:

sudo add-apt-repository ppa:alexlarsson/flatpak # required in 16.04 only, not in later releases
sudo apt update 
sudo apt install flatpak
flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
flatpak install flathub com.valvesoftware.Steam

Steam can be launched by clicking on its icon in the Dash or launched from the terminal with the following command:

flatpak run com.valvesoftware.Steam 

Many games require an online purchase, but some popular games, such as Team Fortress 2, are free to play. When searching in the store, be sure to narrow results by the SteamOS/Linux operating system. Not all Linux games are compatible with your system, so make sure you check the requirements before purchasing games.

|improve this answer|||||
7

The steam package is part of the "multiverse" repository for Ubuntu versios 14.04 onwards, but only for 32 bit versions of Ubuntu. If you want the 64-bit Steam package, you need to add the Steam repository to your sources.

32-bit Ubuntu

  • enable the "multiverse" repository
  • run sudo apt-get update
  • Install steam using either apt-get or the Software Center.

64-bit Ubuntu

or

|improve this answer|||||
4

If it is not possible to find in the Software Center and not possible to install .deb file, then add the source in the software center manually.

Source = deb http://repo.steampowered.com/steam/ precise steam

Now possible to install it !

sudo apt-get install steam
|improve this answer|||||
  • 2
    It should be possible to install it like that without adding the source. – Tim Dec 3 '14 at 8:54
  • 1
    @Tim Only in the 32-bit version. steam is part of the "multiverse" repository, but only the 32-bit version. – That Brazilian Guy Dec 5 '15 at 0:24
2

Using Xubuntu 14.10 x64, from the terminal:

sudo apt-get update && sudo apt-get install steam

This will download and install Steam. Accept the EULA, update Steam, then sign in with your Steam login. BAM! Steam on Xubuntu!

|improve this answer|||||
  • This answer only works for Ubuntu 32-bit. Steam is part of the "multiverse" repository, but only the 32-bit version. If you have use 64-bit, check the other answers. – That Brazilian Guy May 26 '16 at 16:15
0

I confirm that using

sudo apt-get install steam

works fine (still I don't know why steam seems not available on Software Center), however if the application does not appear in menu it is not necessary rebooting, just run

sudo updatedb

|improve this answer|||||
  • Do you use 14.10 or another version? – Thorbjørn Ravn Andersen Oct 27 '15 at 9:50
  • Add the time of the above message, I was using 14.10, recently I installed Steam on a 15.04 without any problem – clobrano Oct 27 '15 at 11:37
  • I don't get why -2 points? – clobrano Dec 5 '15 at 22:26
  • This answer only works for Ubuntu 32-bit. Steam is part of the "multiverse" repository, but only the 32-bit version. If you have use 64-bit, check the other answers. – That Brazilian Guy May 26 '16 at 16:15
  • Is this something new? When I wrote that answer I was using a 64bit machine and it worked – clobrano May 27 '16 at 9:14
0

You will need to install the Steam package manually.

Go to http://store.steampowered.com/about/ and choose the "Install Steam now" link. This will download a debian package (ends in .deb) which you can open directly in the Ubuntu Software Center app. The "Install" button will then install Steam.

It appears it does not show up in the launchbar, but you can search for it (tap the Windows button) and launch it. When launched right-click on the icon to lock it to the launch bar. You can then search for the Steam

|improve this answer|||||
0

If the apt-get install steam doesn't work do the followings

wget https://steamcdn-a.akamaihd.net/client/installer/steam.deb
sudo dpkg -i steam.deb

you may have to rm -r ~/.steam ~/.local/share/Steam directory for removing the old config

If you have problems installing or running it, try following question

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.