I've (perhaps unwisely, it seems) just bought a Brother HL-L2340DW printer and I'm struggling to get it working with Ubuntu.

I need to get it working wirelessly, but I can connect it by USB in order to get it working if necessary.

So far I've managed to get the printer's IP address set and I can browse to it from a web browser, but I haven't managed to get it working as a CUPS printer.

There is no built-in printer driver for this printer in Ubuntu. I tried a Linux CUPS driver from Brother website - the instructions mismatch severely but I sort of guessed my way through the mismatching bits. At the end of it all there are no errors as such, and I can search for network printers, find it and install it, but when I print, the job disappears from the queue without printing or telling me anything went wrong.

To be clear, it's not so much that I'm having problems which I need help to resolve - the issue is that I just don't know how to do this. My first hope is that someone may be able to advise how to do this - and I could then reply with any problems. If that's not possible, it'll come down to debugging it but I just don't know where to start.

Any help much appreciated!

Thanks, Mark


7 Answers 7


Found a better (native, not Google) solution - eventually. This is a pain, but perhaps it will help some poor soul in the future. Unfortunately I can't easily go back and do it again on a virgin system to verify it, so there could be mistakes below - sorry. Better than nothing, though, I hope.

  • Start at http://support.brother.com/g/b/downloadtop.aspx?c=us&lang=en&prod=hll2340dw_us_eu_as (The instructions on this page are terrible, confusing, incomplete, wrong. You need to get the files from there, but here's what I really had to do:)
  • Select OS Family = Linux, OS Version = deb. Click Search.
  • Download both Generic LPR printer driver (deb package) and Generic CUPSwrapper printer driver (deb package)
  • sudo mkdir /var/spool/lpd
  • sudo mkdir /usr/share/cups/model
  • Open the LPR package with Ubuntu Software Centre. Install it. Overlook the badly-made-package warning.
  • Open the CUPSwrapper package with Ubuntu Software Centre. Install it. Overlook the badly-made-package warning.
  • Add a CUPS printer as normal. These are the settings I ended up with, which work for me:
    • Device URI: lpd://Brother/BINARY_P1 ("brother" is set up on my DNS, you could use printer's IP addr, 192.168.x.x)
    • Make and Model Brother BrGenML1 for CUPS (selected from Makes -> Brother, Models -> BrGenML1 for CUPS)
  • 4
    I run 14.10 64-bit. The above got me as far as sending jobs to the printer, but no actual printing. Looks like Brother's driver was missing a dependency, fixed by sudo apt-get install lib32stdc++6. For details, see Brother's Linux FAQ.
    – Daniel
    Feb 2, 2015 at 6:07
  • Daniel's comment and info helped me get it working on 64bit. Thanks for the info
    – Joshua K
    Sep 26, 2015 at 17:28
  • This worked for me as well (14.04 64-bit). If you're using the USB option, this will work too just specify "lpd" instead of "usb". I avoid wireless when I can.
    – user126715
    Oct 6, 2015 at 20:37
  • Fantastic! Thank you! I found that their bash script for installation works well. I also used this instructional video to get the printer connected to my network: youtube.com/watch?v=xeARGVWU-t4
    – Malcolm
    Feb 19, 2016 at 7:09
  • 1
    I'm at ubuntu 16 and support.brother.com/g/b/… was all i need. I selected to download drivers installation tool and just followed the instructions there. Jan 16, 2019 at 15:10

Found another howto. If anyone wants to test this for applicability to the 2340DW that would be great.



I just installed Ubuntu 20 Desktop.

The printer in question was installed automatically.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 20.04.1 LTS
Release:    20.04
Codename:   focal

And for what it's worth, lpstat:

$ lpstat -p
printer HL-L2340D-series is idle.  enabled since Mon 19 Oct 2020 08:43:47 PM EDT
  • 20.04 or 20.10?
    – Zanna
    Oct 21, 2020 at 3:00

I've found a solution - not a great one, but it works:

  1. Get the printer set up with Google Cloud Print.
  2. Install CUPS Cloud Print http://www.niftiestsoftware.com/cups-cloud-print/

Now I can print from Ubuntu -> GCP -> printer. It's a clumsy solution, a bit slow to respond (maybe 20 seconds), the print quality isn't quite as good as printing directly (some slightly odd fringing effects), it uses up my finite data (no idea how much) and adds the (unnecessary but probably not too problematic) restriction that the Internet needs to be alive.


The answer listed above by Mark Smith worked for me (edit: the native solution involving downloading drivers from the brother site, not the Google cloud print one). I didn't need to create the two directories listed as they were already present on my system. Once I installed the two packages I downloaded from the Brother site, I went to add a printer using the regular Printers app on Ubuntu 14.04, in which the Brother now appeared as a local printer (BrGenML1). Right-clicked on properties, then in settings for Device URI I entered "lpd://[printer ip address]" and for Make and Model "Brother BrGenML1 for CUPS" as listed above. Works fine. Thanks Mark!

  • Which answer by Mark Smith are you referring to? There are two, and they might change position.
    – Flimm
    Dec 3, 2014 at 1:20
  • Glad it worked. I think your comment should be a reply to the successful answer, not an answer in its own right.
    – Mark Smith
    Dec 4, 2014 at 18:21

I followed Mark Smith's steps. I also seemed to need " LPR printer driver (deb package)". I used the Generic driver that came with the little printer setup app that comes with Ubuntu. Thanks and HTH. I also rebooted the printer.

  • Also: I used "hl-l235" as the l234 was not listed in the setup app.
    – jouell
    Sep 10, 2016 at 0:21
  • As of 10/20/20 I setup w/o downloading anything using "Elementary OS" and selecting “Brother HL-2170W Foomatic/hl1250” - FWIW
    – jouell
    Oct 20, 2020 at 1:48

Solution for Ubuntu 18.04 (tried and tested just now, all fine incl duplex printing):

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .