0

Okay, so I recently installed Ubuntu 14.04 and from there upgraded to 14.10. My installation is 64bit.

I have installed several other programs and all work fine. For some reason when I try to run Skype it doesn't open up, if I run it from the terminal nothing comes up. However, if I use sudo skype it does run and works just fine. I've tried deleting my /.Skype folder and that momentarily solved the problem until I restarted.

Anyone know how to fix this? Also when I start my terminal I get this before anything else comes on it:

S: Command not found.

  • What error message do you get when you start skype (without sudo) from terminal? How do you start the terminal when it opens with that error message? – Gunnar Hjalmarsson Nov 6 '14 at 20:50
  • I don't get any error message actually, it just doesn't run. Just open it from unity. – user3505901 Nov 7 '14 at 5:37
  • What's the output from the command which skype in a terminal window? – Gunnar Hjalmarsson Nov 7 '14 at 18:17
  • When I type that in this is the output: jose@jose-Inspiron-N5050:~$ which skype /usr/bin/skype – user3505901 Nov 7 '14 at 18:18
  • @user3505901 What is the skype permissions? Run in teminalls -l /usr/bin/skype| awk '{print $1}'. If it was not rwxr-xr-x, type sudo chmod 755 /usr/bin/skype to revert that to default and try to run again with skype in terminal. – αғsнιη Nov 8 '14 at 16:31
1

How to install Skype on Ubuntu

There are several methods for installing Skype on Ubuntu:

From the Skype website (not recommended)

I assume that this is actually what you've did. I actually never used this method because:

  • It provides you a package designed for Ubuntu 12.04. So it might not support well later versions. For example, if there is a dependency renaming between Ubuntu 12.04 and 14.10 versions, it will clearly not support well your version. I can't really tell if the encountered issue is due to this or not.

  • You won't get updates using sudo apt-get update && sudo apt-get upgrade in contrary of the next method.

So if you actually really used this method, first of all uninstall the deb package using: sudo apt-get remove skype

From the Ubuntu partner repositery (the recommended method)

If had not, please read the last paragraph of the previous subsection about uninstalling your current Skype package.

This is the preferred method because it supports better your Ubuntu version. I'm actually using this on Ubuntu 14.10 64-bits.

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner" && sudo apt-get update && sudo apt-get install skype

Please let know if it has fixed your bug or not.

Source: Ubuntu-fr wiki (french)

1

It's probably a matter of setting up the file permissions correctly. Spec. Check that you have rw permissions on /dev/audio and adjust groups accordingly so that you have proper access to relevant devices. Also, if you ran Skype as su, check that ~/.Skype is still accessible to your (non-su) user account.

0

Well I am running Ubuntu 14.04.1 and I am using Skype. Perhaps u downloaded a Windows version. Try this link : http://www.skype.com/de/download-skype/skype-for-computer/ it's the skype for Ubuntu.

  • No :/ that'd require wine and a lot of configuration, I'm sure I downloaded the right one but I'm not sure why this is happening. – user3505901 Nov 7 '14 at 18:19
  • I have one more tipp, download it again fron the site I named. Mine works. – Sebastian C. Nov 8 '14 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.