0

I have tried all kinds of solutions proposed here and in the wild, however, I cannot add my Skype account to Pidgin.

When I open "add new account" dialogue, I can choose between Skype and Skype-Dbus protocol alright. However, when I enter my username and click "Add", pidgin happily dies with either of them. I once got Skype asking, if I want to allow Pidgin to use public API, but since by the time the dialogue appeared Pidgin was dead, it did nothing

What have I tried:

  1. Placing libskype64.so in ~/.purple/plugins

  2. Running apt-get install pidgin-skype

  3. Doing wget http://eion.robbmob.com/skype4pidgin.deb then sudo dpkg -i skype4pidgin.deb

  4. Placing libskype.so in ~/.purple/plugins

I have checked, I have libpurple-bin installed, not sure if that's the libpurple Pidgin uses, but Facebook messaging works.

If it helps, I'm using 64bit Ubuntu 14.10 with gnome-shell DE, Skype-shell integration disabled.

EDIT: I was asked to run pidgin from terminal and post output. Here it is:

Yes, there is no output.

EDIT2: Running pidgin --debug revealed the bug; the two last lines of the output are:

Attempt to unlock mutex that was not locked
Aborted (core dumped)

Googling around I found this bug in bug tracker. People say

I can confirm that compiling and installing libskype64.so from source (r665) fixes the issue.

However, I do not know, how do I compile libraries.

  • Can't help wondering if that plugin is updated to work with Skype 4.3. – Gunnar Hjalmarsson Nov 6 '14 at 15:26
0

This usually should work without any issues. We will start from the beginning. remove skype and pidgin: sudo apt-get remove skype* pidgin*

To get skype to work, you need skype itself installed sudo apt-get install skype and install the plugin like so: sudo apt-get install pidgin-skype. Select Skype. and i think you know the rest

enter code here

Reference:

  • That's exactly what I meant with 2nd try. Pidgin simply shuts down after choosing Skype and pressing Add... (account) – julka Dec 17 '14 at 14:01
  • 1
    @julka run pidgin via terminal, and post the output of that in your Question! – blade19899 Dec 17 '14 at 14:02
  • I did edit my question. – julka Dec 17 '14 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.