I havent used my Ubuntu for quite a long time. Today, when I booted Ubuntu (14.04 LTS), the software updater and Software & Updates (from Settings) are not working.

The software updater's window will show up for around 1 sec, but it will close automatically. Software & Updates is never shown, no matter how many times I click the icon. Note that neither of them show any error message.

Those 2 features were working perfectly the last time I used Ubuntu. I want to do some system upgrade and update.

For now, I use sudo apt-get update && sudo apt-get upgrade. This command runs very fast, meaning (I think) my Ubuntu is not updated properly. The update from software updater always has a big size hence the download should be slower.

What should I do?

Can I just uninstall and reinstall both of them? If I can, how to do it?

Just to clarify, I don't want to upgrade my Ubuntu version (I want the LTS one), I just want to upgrade the software/packages I used.

Thanks for your time.


This is a common thing which is simply solved. These commands clear the "phantom" or "hung" lists and may have to be used again as needed in the future for similar bug:

sudo rm -rvf /var/lib/apt/lists/* 

and then:

sudo apt-get update

You may need to reboot computer for it to effect completely by typing:

sudo shutdown -r now
  • 2
    I'm pretty sure that a reboot is unnecessary here. Deleting cached APT entries takes effect at the next run of APT. – David Foerster May 19 '15 at 7:54

I have almost exactly the same problem as @Blaze Tama and the answer proposed by @Bruce and @edward torvalds did not fix it.

I do not get any error message but when I click on the icons of Software updater and Software & Updates, nothing happens. And Software updater does not prompt me for updates any more.

I am not completely sure that it is the same bug because the sudo apt-get update && sudo apt-get upgrade command seems to work fine for me.

My solution:

  1. Make sure that it is the same bug by running:


My solution should work if your error is:

Traceback (most recent call last):
  File "./update-manager", line 37, in <module>
    from UpdateManager.UpdateManager import UpdateManager
  File "/usr/lib/python3/dist-packages/UpdateManager/UpdateManager.py", line 43, in <module>
    import dbus
  File "/usr/lib/python3/dist-packages/dbus/__init__.py", line 103, in <module>
    from dbus._dbus import Bus, SystemBus, SessionBus, StarterBus
  File "/usr/lib/python3/dist-packages/dbus/_dbus.py", line 39, in <module>
    from dbus.bus import BusConnection
  File "/usr/lib/python3/dist-packages/dbus/bus.py", line 39, in <module>
    from dbus.connection import Connection
  File "/usr/lib/python3/dist-packages/dbus/connection.py", line 27, in <module>
    import threading
ImportError: No module named 'threading'
  1. Download the module 'threading' in your version of Python3

The source code for Python3.4 can be found at https://hg.python.org/cpython/file/3.4/Lib/threading.py . And should be saved in the folder /usr/lib/python3.4. (Or what ever your version of Python3 is. Be careful, in my case, I had this module for Python2.7 but not for Python3.4!)

PS: This bug was described here: https://bugs.launchpad.net/elementaryos/+bug/1415128


Try the following :

sudo apt remove update-manager
sudo apt autoremove -y
sudo rm -r /usr/bin/update-manager
sudo apt install update-manager
sudo apt update
  • 1
    update-manager is different to Software & Updates. – jackw11111 Dec 6 '20 at 4:21
  • 1
    I had the same issue. It was on 18.04 and the latest update fixed it. Apparently it was a bug in the OS and it was fixed. – wbadry Dec 8 '20 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.