2
sudo apt-get check
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libc6 : Breaks: locales (< 2.19)
 libc6:i386 : Recommends: libc6-i686:i386
              Breaks: locales (< 2.19)
E: Unmet dependencies. Try using -f.


sudo apt-cache policy libc6
libc6:
  Installed: 2.19-12
  Candidate: 2.19-12
  Version table:
 *** 2.19-12 0
        500 http://ftp.us.debian.org/debian/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status
     2.15-0ubuntu10.7 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
     2.15-0ubuntu10 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  locales
The following packages will be upgraded:
  locales
1 upgraded, 0 newly installed, 0 to remove and 1655 not upgraded.
1 not fully installed or removed.
Need to get 0 B/3,916 kB of archives.
After this operation, 7,282 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  locales
Install these packages without verification [y/N]? y
dpkg: dependency problems prevent configuration of locales:
 libc6:i386 (2.19-12) breaks locales (<< 2.19) and is installed.
  Version of locales to be configured is 2.13+git20120306-3.
 libc6 (2.19-12) breaks locales (<< 2.19) and is installed.
  Version of locales to be configured is 2.13+git20120306-3.
dpkg: error processing locales (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Errors were encountered while processing:
 locales
E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo dpkg --configure -a  dpkg: dependency problems prevent configuration of locales:  libc6:i386 (2.19-12) breaks locales (<<
2.19) and is installed.   Version of locales to be configured is 2.13+git20120306-3.  libc6 (2.19-12) breaks locales (<< 2.19) and is installed.   Version of locales to be configured is
2.13+git20120306-3. dpkg: error processing locales (--configure):  dependency problems - leaving unconfigured Errors were encountered while processing:  locales
6
  • Have you tried sudo apt-get -f install?
    – Pandya
    Nov 6 '14 at 6:42
  • Yes I did, see above
    – Rpj
    Nov 6 '14 at 6:44
  • I don't think its a duplicate of the above issue, this is quite different
    – Rpj
    Nov 6 '14 at 6:45
  • Try sudo dpkg --configure -a what happens?
    – Pandya
    Nov 6 '14 at 6:45
  • I get the same error, see bug description.
    – Rpj
    Nov 6 '14 at 7:43
0

I also had similar problem 'packages have unmet dependencies' and the only solution that worked for me is to purge and reinstall all the unmet dependencies and their parents.

4
  • This is libc6, how do I purge that wont the system go for a toss
    – Rpj
    Nov 6 '14 at 7:49
  • @Rpj may be sudo apt-get purge libc6 first.
    – Pandya
    Nov 6 '14 at 8:51
  • @Rpj not sure about that though, sorry! Nov 6 '14 at 9:50
  • purge libc6 is pretty dangerous. may break everything else
    – thang
    Aug 21 '19 at 0:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.