0

I am trying to install aircrack-ng but I keep getting this error when I run make.

make -C src all
make[1]: Entering directory `/home/development/aircrack-ng-1.2-rc1/src'
gcc -g -W -Wall -O3 -D_FILE_OFFSET_BITS=64 -D_REVISION=0  -DCONFIG_LIBNL30       -DCONFIG_LIBNL -I/usr/include/libnl3   -Wno-unused-but-set-variable -Wno-array-bounds -Iinclude  wpaclean.o osdep/radiotap/radiotap.o -o wpaclean -Losdep -losdep -lnl-genl-3 -lnl-3  
/usr/bin/ld: cannot find -lnl-genl-3
collect2: ld returned 1 exit status
make[1]: *** [wpaclean] Error 1
make[1]: Leaving directory `/home/development/aircrack-ng-1.2-rc1/src'
make: *** [all] Error 2

I have run apt-get install libssl-dev build-essencial and I have changed the line CFLAGS ?= -g -W -Wall -Werror -O3 to CFLAGS ?= -g -W -Wall -O3, so I don't know what the issue is.

1

That's linking error about missing lib:

/usr/bin/ld: cannot find -lnl-genl-3
  1. As aircrack-ng is in repository, install build dependencies using:

    sudo apt-get build-dep aircrack-ng
    
  2. Carry on installing missing ones which are not checked by ./configure:

    sudo apt-get install libnl-genl-3-dev
    

You can use Synaptic to search for missing development lib, most have lib prefix and -dev suffix.

| improve this answer | |
  • I tried the first command and I got an error saying apt-get couldn't find the package. – user346070 Nov 6 '14 at 5:59
  • @EliasLawson-Fox, Sorry it seems aircrack-ng dropped in 12.04 release. packages.ubuntu.com/… . Try use second to resolve them one by one. – user.dz Nov 6 '14 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy