I have a 16 gb transcend pen drive. One day I had partitioned into 4, and on one part I had installed ubuntu 11.04. But after that it seems the usb won't auto mount. I have used the fdisk utility and observed that my OS (ubuntu 10.04) is detecting the pen drive but not connecting to it, and making it available to my file system. I used fdisk to re-partition it, but this time I removed all partitions. Still it is not being detected by the file system (i.e. not auto-mounted)?

Update 27th Jul 2011 10.47 p ist:

The usb drive was re-partitioned to have a single FAT 32 partition on which the boot flag was set. While trying to mount nautilus gave me the following error:

enter image description here

I'm also including the log messages in the following paste.


  • Can other USB drives be auto-mounted? How is the pen drive partitioned and formatted now? – Takkat Jul 26 '11 at 20:09
  • There is now only 1 partition. Here is a paste showing details when I ran fdisk -l --> pastebin.com/5RdaCvEE – deostroll Jul 26 '11 at 20:31

USB drives are auto-mounted when Nautilus is set to do so. In case all USB drives fail to mount we may check if this is the case (and to enable or disable auto-mounting) by opening gconf-editor from a terminal and browse to apps/nautilus/preferences:

enter image description here
Default settings shown here

From there the key media_automount needs to be ticked in order to allow mounting an USB drive when plugged in.

Rarely after a failed partitioning with Gparted we may encounter a problem with a persistent policy key that was set up (but not removed) to prevent mounting of drives while partitioning. Restarting Gparted should solve this issue.

Mounting USB drives independent of Nautilus can also be done with usbmount Install usbmount

  • Other usb drives are working fine...the problem is only with this transcend usb. I can manually mount it as root user. – deostroll Jul 27 '11 at 6:34
  • I don't know the significance of the first question. Boot flag - it is set to have a boot flag. Have you checked the paste? This is what you meant I hope... – deostroll Jul 27 '11 at 6:43
  • okay. i've updated the question... – deostroll Jul 27 '11 at 17:41
  • uhm - you know that for FAT32 the upper size limit is 4 GB? – Takkat Jul 27 '11 at 19:08
  • erm, I don't know the significance of that either! – deostroll Jul 27 '11 at 19:20

Usb must be FAT32 to work correctly .. So after what you did, you shoud formating a new partition table too to msdos.. After this you can create a FAT partition. Pay attention, this procedure will erase all files on your drive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.