6

I just upgraded to Ubuntu 14.10 (from 14.04). When I unplug my external monitor (I'm on a laptop so this happens often) the mouse gets a second pointer just below the normal one but rotated 90° counter-clockwise. I think the rotation is due to the external monitor also being rotated 90° counter-clockwise. The double mouse pointer sometimes goes away if I restart gnome-shell, but often stays.

Here's a photo of the result (a screenshot wouldn't capture the pointer): http://imgur.com/Qt71709

  • I'm getting this exact issue too! I also use a 90degree-rotated monitor on my Ubuntu 14.10 desktop – Greg Mar 3 '15 at 14:14
7

Not an answer as such although I did inadvertently get rid of the second cursor!

I am getting the same issue - intermittently - since I upgraded from 14.04 as well.

Interestingly, the "solution" was to mouse over the image you posted! I opened it to see if it was the same issue as mine and just as I was noticing the top pointer appears to be the "active" pointer in that it changes icons as the context changes - the second pointer vanished as I moved it out of the image window!

It hasn't reoccured even though I've moved it from window to window (one of my screens is also rotated 90 degrees) and I've swapped windows. Yet to reproduce the problem but I'm bookmarking this issue to see if mousing over and then out of the image window works again!

  • Yeah I also found that if I went into "Tweak Tool" and changed the cursor theme to something else and then back it would work, but again there not all cursor themes would get rid of the duplicate. Very strange... – labarna Nov 12 '14 at 22:48
  • 1
    It's happened to me a couple of times but fixed itself when I moved windows. This morning it got 'stuck' on the double cursor again and nothing made any difference = so I opened this page and clicked on the image ... and it worked! No idea why but there you go. – jackcorbae Nov 30 '14 at 22:05
  • Hey @jackcorbae, did you ever find a permanent solution for this? – Sindri Guðmundsson Dec 30 '14 at 14:05
  • I didn't. But I've also started a new job so I no longer have access to a linux workstation with dual monitors. Home only has one ... I should do something about that! :) – jackcorbae May 29 '15 at 1:57
  • Mousing over the linked image worked for me as well. – wachr Jun 2 '15 at 21:20
2

It's a Xserver-Xorg-Video-Intel Package BUG. Fixed upstream apparently though. Still waiting for the fix to land in 14.10.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.