22

I am using a KDE desktop on a "normal" Ubuntu installation. At one point I set up some chat accounts but I stopped using them a year or so ago. Now I want to get rid of the system tray icon for chat. But, I cannot find any way to quit the application, nor can I find a setting to disable the "start at login" feature.

When I right-click the icon, the only "options" or "preferences" selection I see is "Instant Messaging Presence Settings" which brings up some sort of keyboard shortcut dialog. If I double-click, the "KDE IM Contacts" window pops up. Here I can go into "Instant Messaging Settings". But neither "Accounts" nor "General" nor "Notifications" tabs have any options that seem to control startup.

How can I get rid of this application? I don't want it and don't use it, but it is part of the base package, so I'm pretty sure it will just re-install on upgrades if I try uninstalling it, plus somebody else on the computer may use it at some point.

28

If chat is starting at login, you can open the settings window from the contacts list, go to the "General" section, and uncheck "Restore last presence on login".

That doesn't disable the instant messaging icon in the panel (it just shows "offline" when it's not running). To get rid of the icon, right-click an empty space in the system tray (e.g. between icons) and choose "System Tray Settings". Go to the "Display" section and uncheck "Instant Messaging Presence".

| improve this answer | |
  • Thanks so much! I had the "restore last presence" disabled already, I didn't know about the tray settings. I'm a little worried that it's using system resources without the icon being displayed. But I'm guessing its negligible, especially without being signed in. – Ben Nov 25 '14 at 3:49
17

It might be a little late but I just found out an easier method, in case anyone ever wonders in the future.

Go to "System Settings -> Startup and Shutdown -> Background Services". In the lower box which is labeled "Startup Services" you will be able to check and uncheck services in the "Use" column. Uncheck "Accounts" if you want to disable the Instant Messenger on startup which will also disable the tray icon. Log out and in again to see the change.

By the way, I am using Kubuntu 15.10.

| improve this answer | |
  • This is definitely useful information, but Accounts sounds like it might control more than just IM, I will need to do more research before using this solution. – Mike Lippert Jul 11 '17 at 15:33
6

You should uninstall kde-telepathy-desktop-applets package:

sudo apt-get remove kde-telepathy-desktop-applets

It should not get installed normally on upgrades.

Then re-logout into your KDE session. To apply changes to your taskbar immediately without re-logout restart plasmashell process:

pkill plasmashell; plasmashell &

Still if you want to make sure this package won't get installed (I've seen it installed automatically when upgrading 17.10 to 18.04) eventually you can blacklist it (see https://askubuntu.com/a/249447 for details) by creating /etc/apt/preferences.d/kde-telepathy-desktop-applets_blacklist file with the following content:

# Prevent this plasmoid from being installed.
# See https://askubuntu.com/a/995094 for details.
Package: kde-telepathy-desktop-applets
Pin: release *
Pin-Priority: -1
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.