This question already has an answer here:

I understand that there have been several fixes to this exact problem in the past, but I have tried them all and nothing has worked. The external speakers output sound just fine but the headphones do not. Interestingly enough, they do play a bit of static when I plug them in. That's about all that I can tell you except that I'm running Ubuntu 14.04 off of a flash drive (dual booting Windows) and I have a Dell machine.

I've tried the solutions listed here: Headphone jack not working?

and a few from other random sources around the internet. I've made sure to completely shut down my machine after each attempted fix. I made sure to unplug and replug the headphones after Ubuntu booted up.

Should I just try and update Ubuntu? I'm a bit new to Linux in general so I'm sorry for being such a noob. Any help is greatly appreciated. Thanks

marked as duplicate by Eric Carvalho, Charles Green, muru, αғsнιη, mniess Nov 10 '14 at 11:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


Have you tried checking Pulse Audio Control? You can sometimes track down problems in the settings there. In case it's not already installed:

$ sudo apt-get install pavucontrol
$ pavucontrol

Click on the Configuration tab, and check that the Profile is set to something sensible (e.g. "Analog Stereo Duplex"). Then go to the Output Devices tab, and check you can see your headphones listed in the dropdown box (and check that they are not muted).

You have my sympathies -- headphone problems can be a nightmare to track down sometimes.

  • 1
    I installed Pulse Audio Control as you suggested and I fiddled around a little bit, but to no avail. I noticed in the "Output Devices" tab it has the option to select headphones, but it says they're unplugged. Selecting that option will do nothing and sound will still be output through the speakers. – Matthew Harris Nov 5 '14 at 23:21

I had recently the same problem on a pc (headphone jack bad, internal speaker ok):
To have headphone jack working, I have now to activate "loopback" switch in Alsamixer :

  • In a maximized terminal, launch alsamixer.

  • If you see only one fader ( HDMI soundcard, ), press F6 , select the second device ( use arrow keys to highlight the 2nd device then press enter key) .

  • If main sound card is selected, you see many faders: scroll to extreme right searching "loopback" switch, enable it with "up" arrow key:
    On my pc , headphone works again.

Note: this looks like a bug as "loopback" switch goal is to record the playing source instead of mic/line input.

Not the answer you're looking for? Browse other questions tagged or ask your own question.