2

I am working on an Ubuntu 14.04 Live system.

On every boot it displays the same "Keyboard Shortcuts" overlay that is shown when you press the Super key for two seconds.

enter image description here

This is a nice feature for a normal install, but I would like to disable it for the live system.

I have tried running this in the chroot (used for creating the live system) and on startup (using /etc/rc.local) but it doesn't help.

dconf write /org/compiz/profiles/unity/plugins/unityshell/shortcut-overlay false

How can I disable this overlay?

1

After a lot of trying I figured out a way.

My final solution is adding the file /etc/profile.d/overlay.sh. In it I have this line, which disables the overlay (same effect as the command in the question).

gsettings set org.compiz.unityshell:/org/compiz/profiles/unity/plugins/unityshell/ shortcut-overlay false

This file is executed whenever a user logs in, so it even works when it's the first time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.