1

Kubuntu 14.04

Whenever I attempt to SSH into a server with a private key, I am asked to

Enter password to unlock the private key

However, this then remembers the password until I completely log out, without giving me the option for it to be a one-time thing.

I'd like to prevent this dialog from opening when using keys for SSH.

I've tried

gconftool-2 --set -t bool /apps/gnome-keyring/daemon-components/ssh false

and

sudo ln -sf /dev/null /etc/xdg/autostart/gnome-keyring-ssh.desktop
sudo ln -sf /dev/null /etc/xdg/autostart/gnome-keyring-gpg.desktop

without any luck.

Edit

It would seem to be gnome-keyring-daemon, ignoring its setting to not do it for ssh.

1

I've taken to stopping the process from running with a few lines inside my users' .bashrc file.

gkd="$(pidof gnome-keyring-daemon)"
if [ "_$gkd" != "_" ];then
    kill -9 $gkd
fi

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.