4

I am new to Ubuntu. I finally decided to dual boot (I need windows for ONE program: ArcGIS). Everything was going fine until I took my laptop to class and realized my battery power was draining like crazy (1.5 hours remaining at the start of a 3 hour lecture).

Due to this predicament, I decided to try out tlp. I followed a guide online on how to install tlp through the terminal and my Wifi stopped working.

How can I fix it?

3
  • Hey! Quick update! I can indeed connect to my Wifi (the router/modem is about 25 feet away from me in the living room) only if the ac power is connected. However, there are two things that might be worth noting: 1) The internet icon at the top right shows a monitor as opposed to the wifi signal icon. 2) My power just drained from 97% to 5% in a matter of seconds. – George Nov 5 '14 at 5:58
  • 2
    Please try turning off power management for the wireless: sudo iwconfig wlan0 power off. If it helps, we'll make it permanent. – chili555 Nov 5 '14 at 14:42
  • 1
    Hah! I've been at it for hours yesterday and that's all it took.. Thank you so much, Chili555! – George Nov 5 '14 at 16:37
5

To disable wifi powersave in TLP permanently on battery you don't have to fiddle with iwconfig or rc.local (won't work reliable anyway).

Change the following line in TLP's configuration instead:

WIFI_PWR_ON_BAT=N 
4
  • 1
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include all the essential parts of the answer here, and provide the link for reference. – MadMike Nov 6 '14 at 18:33
  • 1
    Only Ubuntu 17.04 has TLP 0.9. – JauntyDoe Apr 17 '17 at 15:00
  • Ubuntu 16.10 and 16.04 has 0.8. I reckon "N" does not work on TLP version 0.8? – JauntyDoe Apr 17 '17 at 15:02
  • @JauntyDoe: Wrong. 0.8 works with Y/N. Was invented many years ago :-). – linrunner Apr 18 '17 at 20:17
0

There are several ways to permanently disable power management. The easiest is:

gksudo gedit /etc/rc.local

Use nano or kate or leafpad if you don't have the text editor gedit. Right above exit 0, add a new line:

iwconfig wlan0 power off

Proofread carefully, save and close the text editor. If this is ineffective, for some reason, we'll try something else.

0

I faced the same problem,

I fixed my problem by

Uninstalling TLP and Installing Wireless Drivers

Command: (to remove tlp) (sorry I have OCD)

sudo apt-get purge tlp
sudo apt-get autoremove
sudo apt-get clean all
sudo apt-get autoclean

Command: (to install 802.11 drivers) (I am on Kali rolling and using Wicd network manager)

sudo apt-get install firmware-brcm80211 firmware-b43-installer firmware-b43legacy-installer broadcom-sta-dkms

if you don't know the repository of Kali: ( Paste this in /etc/apt/souces.list and save )

deb http://repo.kali.org/kali kali-rolling main contrib non-free

I also noticed, while installing tlp, the package arping was replaced by iputils-arping. Hence,

sudo apt-get install arping

Restart Required

Thats it!

(if this works for you, please upvote so I can get right to answer, comment, upvote, etc)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.