78

In Gnome Tweak Tool, I'm unable to change the Shell theme:

Hovering over the exclamation mark shows the following tool-tip: Shell user-theme extension not enabled. I'm using Ubuntu 14.10, and have installed gnome-shell-extensions.

2
  • Are you actually using gnome shell or are you using ubuntu with unity desktop?
    – xangua
    Nov 4 '14 at 21:19
  • I'm using gnome shell. I managed to solve the problem myself. See below.
    – miceagol
    Nov 6 '14 at 20:43
81

I solved this problem myself, and it was an extremely trivial solution:

  1. Open Gnome Tweak Tool.
  2. Click on the Extensions menu item, and move the User themes slider to On.
  3. Close Gnome Tweak Tool and open it again.
  4. You should now be able to choose a Shell theme in the Appearance menu.
4
  • 3
    If you just installed gnome-tweak-tool, you may need to log out/in before the extensions appear. Nov 29 '15 at 3:06
  • 9
    Do you know what one should do if there is no slider turn it on? Apr 26 '19 at 3:03
  • 5
    Hello from 20.04 and 18.04... there is no "user themes" slider.
    – Rabbit
    May 26 '20 at 11:43
  • 3
    @Rabbit, you need to install extensions.gnome.org/extension/19/user-themes .
    – Alexey
    Jun 27 '20 at 23:04
34

In addition to @miceagol's answer: If you do not see User Themes in the Extensions panel of GNOME Tweak Tool, you may need to install it from extensions.gnome.org. Restart the tweak tool after installing.

2
  • To do so, one can launch sudo apt install gnome-shell-extensions and might need to logout.
    – JKHA
    May 7 '20 at 5:41
  • 1
    I just tested on Ubuntu 20.04 and the apt package did not install the gnome shell extension for Firefox. I still had to go to extensions.gnome.org. I suspect, that you need to do both: the.org installs the browser extension and the apt package installs the system elements. May 7 '20 at 15:53
3

You can set a theme using Terminal :

 sudo chmod -R 755 /usr/share/themes/Zukitwo
gsettings set org.gnome.desktop.interface gtk-theme "Zukitwo"
gsettings set org.gnome.desktop.wm.preferences theme "Zukitwo"
gsettings set org.gnome.shell.extensions.user-theme name "Zukitwo"

use a known working default theme like above and it should get you back but this below may be your real nightmare are thems that won't work.Installing themes that don't work LEAVE behind entries and if you click on a failed entry you will break the tweak tool.

Uninstalling a themes not that easy though..No idea how to remove a bad theme from the list in tweak tool.

2
  • This is a good answer. Let's stick with the gnome default themes.
    – ukos
    Aug 9 '18 at 9:20
  • 1
    No such schema “org.gnome.shell.extensions.user-theme”
    – Suzana
    Jan 31 '20 at 16:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.