4

Please pardon my inexperience with Linux and related packages. I am very new to such systems.

I have installed Ubuntu 14.04 in a Windows Hyper-V virtual machine (VM). For a VM on a Windows host, instead of connecting through the Hyper-V Manager, it is suggested to connect to a VM with a remote desktop connection (RDC). To connect to the Ubuntu VM with the Windows terminal server RDC, I installed the Xrdp package in the Ubuntu VM. To sidestep 3D complications with the Unity desktop interface, I installed the Xfce4 package in the VM. Things work generally well.

However, mouse scrolling is very slow. In other words, it takes several scrolls of the mouse wheel to scroll the display of various windows.

Upon further inspection, I found the mouse settings (Application Menu/Settings/Mouse and Touchpad) are not present (other settings such as the Keyboard are present). In particular, I tried the following command to evaluate Xfce4 mouse settings, however I received a message about Xlib that might be related to Xrdp:

$ xfce4-mouse-settings
Xlib:  extension "XInputExtension" missing on display ":10.0".
(xfce4-mouse-settings:14760): xfce4-mouse-settings-CRITICAL **: XI is not present.

Here is my main question:

1) How can I improve/increase the mouse scroll speed in Ubuntu 14.04 with Xfce4 and Xrdp?


However, the situation also leads me to ask the following questions:

2) How can I install the Mouse and Touchpad settings in Ubuntu 14.04 with Xfce4 and Xrdp?

3) Is Xrdp a preferred RDC for Ubuntu 14.04 in a Windows Hyper-V VM?

4) Is Xfce4 a preferred desktop interface for Ubuntu 14.04 in a Windows Hyper-V VM?


Thanks for any ideas or suggestions you may have!

3

Here's my own answer, or maybe it could be considered a slightly-adjusted, alternative solution. Upon further diagnosis, here is what I found:

A) The command xset worked on both the Hyper-V Manager Connect session and the Xrdp session. Unfortunately, it only allows three mouse movement (not scrolling) parameters: acceleration multiplier, acceleration divider, and pixel threshold for applying the acceleration parameters.

B) Looking further into the X (X11?, Xsession?, Xorg?) settings, there are additional mouse options. The command xinput worked on the Hyper-V Manager > Connect session but did not work on the Xrdp session. So, it appeared that the Xrdp session somehow did not make use of many (or any) X settings, which apparently help with the graphical user interface in aspects such as the display, keyboard, and pointers (like the mouse).

C) Just now (after-the-fact), scouring my history to find related commands that might be of interest, in addition to xset and xinput, I found: X, Xserver, xterm, xrandr, xsetpointer, xfconf-query. (I expect these will help in a local connection or a Hyper-V Manager > Connect session, not in an Xrdp remote connection.)

D) Reading about how Xrdp and other remote connection programs work, it seems to me that the Xrdp version (v0.6) that I first used might have been using the VNC protocol, which to my understanding does not use X settings. I further found that another package, X11rdp, might make use of more X settings in an Xrdp remote desktop session.

E) Finally, I found a very helpful pair of scripts that helps to download and build packages for debian (which Ubuntu is based upon). The scripts, by www.scarygliders.net, are X11rdp-o-matic.sh and RDPsesconfig.sh. Very helpful documentation is provided at http://scarygliders.net/x11rdp-o-matic-information/ , however, other pages on that site as well as pages on www.xrdp.org and http://sourceforge.net/projects/xrdp/ will likely round out the information you might need. After downloading a repository with git, the X11rdp-o-matic.sh took quite some time to do its work. At the end of the script, a message stated that X11rdp and Xrdp were installed and were expected to be running. It was also suggested that I might not need to run the RDPsesconfig.sh script, but instead just try to login with a Remote Desktop Connection, which is exactly how it worked out. One thing I wish that I had done is to use the option to install audio sound, but the recommended option to --justdoit, with the latest stable Xrdp version (--branch v0.8), really provided all that I currently need.

In conclusion, X11rdp-o-matic.sh helped to download, build, and install the latest stable versions of X11rdp and Xrdp. This configuration provides a way to use Windows Remote Desktop Connection terminal server to connect to a Windows-hosted Hyper-V virtual machine with Ubuntu 14.04 installed. The Xrdp connection is quick and responsive and some of the X settings that I know of (such as some of those listed in C, above) appear to be available in the remote session (thanks to X11rdp). Copy and paste both into and out of the remote session work well. The mouse scrolling issue is resolved; it is fast enough and smooth enough. I might only consider using the option to include audio sound in the future.

MANY THANKS to the authors and contributors to Xrdp, X11rdp, and X11rdp-o-matic!

1
  • Seems like maybe rdp-o-matic stopped working in ubuntu 15.10.. sad days – bwawok Mar 19 '16 at 22:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.