4

I installed Lubuntu 14.04 on an old computer, and I'm trying to use its floppy drive, since it's the fastest way to move small files from it to my other computers.

I'm having troubles, though, since apparently only root has the rights to work with it; with my normal user rights I can only see the files, not edit them, as you see in this screenshot:

Screenshot, floppy properties

Of course I can copy files on the floppy from the terminal, by writing things like sudo cp -file's directory- /media/floppy0, but that's a pain.

So my plan is to become, at least temporarily, owner of the floppy drive, so that I can change, hopefully definitively, the rights. I looked for solutions all over the web, here and on other websites, without success.

For example I tried to write sudo chown alex:alex /media/floppy0, but it says I don't have the permission for that. I tried sudo chown -R alex:alex /media/floppy0, which worked only one time, and just temporarily (since it all returned as it was before after I mounted the floppy again); now it says I don't have permission for that anymore.

I also modified some files, without success too. Here they are.

In /etc/fstab I've added the last two lines. The last one now has a # before it, because I was experimenting with it, without success of course. I read that I had to do this on an other website. I'm not sure I can link it.

alex@Ermac:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=845740a8-88b5-4ed7-8e2a-786a5ed8c61d /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=939cac21-ee73-4249-aafd-3c8e59e81501 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
# /dev/fd0        /media/floppy  auto    rw,user,noauto,exec,utf8 0       0

Here is /etc/modules. Here I added the last line, as I read on the same website as before. I tried by writing both "floppy" and "floppy0". Neither of these solutions worked.

alex@Ermac:~$ cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
# Parameters can be specified after the module name.

lp
floppy0

I also changed this part of /lib/udev/rules.d/80-udisks.rules, according to a second solution that didn't work for me, as the other one. Those two 0s where 1s:

alex@Ermac:~$ cat /lib/udev/rules.d/80-udisks.rules
...
# PC floppy drives
#
KERNEL=="fd*", ENV{ID_DRIVE_FLOPPY}="0"

# USB floppy drives
#
SUBSYSTEMS=="usb", ATTRS{bInterfaceClass}=="08", ATTRS{bInterfaceSubClass}=="04", ENV{ID_DRIVE_FLOPPY}="0"
...

So... any other idea? :\

  • Have you tried to add uid=<your user id> to the list of options in /etc/fstab? Or --- I do not know if lubuntu uses the udisks system; using udisksctl mount --block-device /dev/floppy0 (or floppy) should take care of all the permission thing and mount it in /media/alex/floppy or something similar. – Rmano Nov 4 '14 at 15:50
  • The use of a floppy drive might be "inappropriate use of possibly unsupported technology". Why can't you use a flash drive to transfer files? Do both computers support flash drives? Flash drives are more recent technology and will be better supported. – Bulrush Nov 4 '14 at 19:00
  • @Bulrush: I can't use it because the USB doors of this computer are a few and are uncomfortable, since they are behind the case, which stands in such a position that would require me to move it every time I'd like to use a flash drive. I could buy an extension and a multi-plug to solve the problem, but most of the time I don't have free USB doors on my laptop too. Whatever, now I'll try to edit fstab as Rmano said. – il mietitore Nov 6 '14 at 10:44
  • @Rmano: It worked! Now when I mount a floppy I am its owner! Thank you! – il mietitore Nov 6 '14 at 11:06
3

So this was solved thanks to Rmano: I had to add uid=<my user id> to the list of options in /etc/fstab. So, the final line becomes:

/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8,uid=<my user id> 0 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.