If I start typing a command like apt-g after hitting tab, the shell completes the command to apt-get, but for the second part of the command like install, if I enter some characters like insta, hitting tab, doesn't complete it to install.

Another example: after I enter sudo hitting tab doesn't complete anything. for example: sudo apt-ge [tab] and nothing.

I installed Ubuntu using mini iso (40MB network installer), so maybe there is a config that I missed!

I've added this code to my .bashrc but still it does not works:

if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion

I have also checked the permission of .bashrc and it's -rw-r--r--.

I also source the .bashrc after changes using source .bashrc to apply the changes to the new environment but still no effects.

I use xfce4-terminal so I thought it might be the terminal and not the bash.

But editing:


And changing:

<property name="&lt;Super&gt;Tab" type="string" value="switch_window_key"/>


<property name="&lt;Super&gt;Tab" type="string" value="empty"/>

Doesn't makes any difference too.


4 Answers 4


bash-completion is a set of bash scripts which enables customized completion for specific commands.

This is not just for files and directories, but also e.g. for the commands. So you type partial of commands and by hitting Tab we get a auto completion of commands.


Step 1: Install bash-completion

$ sudo apt-get install bash-completion

And some times it works if we re-installed it by the follwing command:

$ sudo apt-get install --reinstall bash-completion

Step 2: Enable bash-completion in your .bashrc file

Open your gedit ~/.bashrc and if these content doesn't exist there, add them at the end of it and save it.

# enable bash completion in interactive shells
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion

Important: After changing the file you need to source your ~/.bashrc with source ~/.bashrc or reopen your Terminal. It should be fixed now.

  • 2
    I would like to confirm that adding the above block of code to the ~/.bashrc file did work for me. Just one comment; you don't really need to log out and log in again to make it work (you may not want to terminate what you work in), you could just run source ~/.bashrc. Dec 1, 2016 at 18:35
  • 1
    I had to reopen the Terminal in order for it to work! Mar 29, 2017 at 13:17
  • 4
    Completion suddenly stopped working for me, the above steps do not fix the issue. Any ideas on how to troubleshoot the issue? On ubuntu 16.04 Feb 6, 2018 at 18:36
  • 2
    Step 2 does it for me. Or get the template from /etc/skel/.bashrc May 3, 2018 at 15:48
  • 1
    @SergioIvanuzzo not sure what issue you are facing you may look at this unix.stackexchange.com/q/219342/72456 it helps, else open your own question for the problem you have. Aug 1, 2019 at 12:41

If your case is terminal tab not working under Xfce, the solution is as follows:

  1. Open Application Menu > Settings > Window Manager.
  2. Click on 'Keyboard' tab.
  3. Clear the 'Switch window for same application' setting.

Window Manager screenshot how to clear switch window for same application

I've found the solution here.

  • Tried accepted awnser, but everything was already in place. This was indeed the solution for me. Nov 24, 2016 at 14:35
  • 2
    Still the solution I needed as of May 2018.
    – clifgray
    May 28, 2018 at 15:06
  • 1
    Needed this once I connected through xrdp Dec 20, 2019 at 21:52

You may also be in a shell that doesn't support auto complete (ex: Bourne Shell | SH). If you want BASH auto complete you need to switch shells, say to BASH (Bourne Again SHell) instead with the command

chsh -s /bin/bash

Source: Ubuntu Wiki - Changing Shells

  • Alternatively just hit bash and it works
    – mahi_0707
    Sep 24, 2023 at 10:32

In my case, I was trying to execute a script ./myScript.sh, and typing ./my[tab] would not auto-complete.

I had to add execute permissions to the file and auto-completion worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .