3

Yesterday I faced a similar problem with the one presented here: Screen Resolution Problem with Ubuntu 14.04 and VirtualBox only that I was having the issue in VMware.

I provided the answer there but Sylvain Pineau suggested that I should ask the same question and answer it myself.

That's what I will do below...

  • If the other answers won't work try to increas video card memory in the VM settings. It worked for me. – Vladik Y Jul 25 '16 at 16:34
  • You have to edit the video card to set the amount of memory. That allows you to select the resolution you want and will auto populate the memory field. The hint was askubuntu.com/questions/545536/… it says 8M but that will not work for todays highest resolution settings. – kkron May 17 '17 at 22:12
7

My configuration is host : windows 7 and vmware guest : ubuntu 14.04. For long time I've seen if I update the vmplayer or some software in vmplayer that screws my display and then in full screen it can no longer capture host display.So today I just followed the instruction provided in this link and fixed it without installing any additional software.I hope it helps other.

At first run :

$ xrandr -q

tanay@ubuntu:~$ xrandr -q Screen 0: minimum 1 x 1, current 1904 x 1070, maximum 8192 x 8192 Virtual1 connected primary 1904x1070+0+0 (normal left inverted right x axis y axis) 0mm x 0mm    800x600       
60.0 +   60.3      2560x1600      60.0      1920x1440      60.0      1856x1392      60.0      1792x1344      60.0      1920x1200      59.9  1600x1200      60.0      1680x1050      60.0      1400x1050      60.0  1280x1024      60.0      1440x900       59.9      1280x960       60.0  1360x768       60.0      1280x800       59.8      1152x864       75.0  1280x768       59.9      1024x768       60.0      640x480        59.9  1904x1070_75.00   74.9*  Virtual2 disconnected (normal left inverted right x axis y axis) Virtual3 disconnected (normal left inverted right x axis y axis) Virtual4 disconnected (normal left inverted right x axis y axis) Virtual5 disconnected (normal left inverted right x axis y axis) Virtual6 disconnected (normal left inverted right x axis y axis) Virtual7 disconnected (normal left inverted right x axis y axis) Virtual8 disconnected (normal left inverted right x axis y axis)

Then you can see which output is connected,here Virtual1 is connected. Then guess a good resolution for your screen.For me I guessed following configuration.

Eg:cvt <horizontal length> <vertical length> <refresh rate>

$ cvt 1900 1070 75

The output is

# 1904x1070 74.87 Hz (CVT) hsync: 83.85 kHz; pclk: 216.00 MHz Modeline "1904x1070_75.00"  216.00  1904 2040 2240 2576  1070 1073    1083 1120
-hsync +vsync

Then you need to copy the text after "Modelline" and paste that in following command like the example below

$ xrandr --newmode "1904x1070_75.00"  216.00  1904 2040 2240 2576  1070 1073 1083 1120 -hsync +vsync

Then take the screen resolution details from the quote and use it in next command.For me the command is

$ xrandr --addmode Virtual1 1904x1070_75.00

The next command to set it in ubuntu for me is

$ xrandr --output Virtual1 --mode 1904x1070_75.00

If the last command doesn't work for you,you can go back to ubuntu display gui setting and can chose the display you have added just now.For me the option was 1904 x 1070 (16:9)

However if you are fine with this experiment and have found the desired screen resolution and to make that permanent,write the all the last 3 commands starting from xrandr --newmode command in your .xprofile file using following command and then save,exit and restart your ubuntu vm and you will get your desired resolution permanently.

$ gedit ~/.xprofile
4

Symptom:

Each time you start/restart a virtual machine in VMware it starts in low resolution initially. Then, once you switch to full screen the resolution goes to full-screen (given that VMware tools are installed previously)

Solution:

When the VMware starts in small screen, do not switch to full-screen mode.

  1. Go to Displays settings within your Ubuntu 14.04 Guest: System Settings -> Displays, then try to switch to the desired resolution from the drop-down menu.

  2. If the screen is too small to press the Apply button, make sure that your current selection is at the drop-down menu with the desired resolution.

  3. Now, press Tab key in your keyboard 7 times, this should have brought your selection to the Apply button.

  4. Press Enter

This worked for me, hope works for the others as well.

  • What display settings are you referring to? Host or Guest? – Mitch Nov 4 '14 at 17:49
  • Guest; added to the answer. – Kristof Tak Nov 4 '14 at 18:02
  • That is not possible with the guest OS. see Here. If you mean from the host OS, I don't think that it works. Can you supply a image of that? Thanks – Mitch Nov 4 '14 at 18:12
  • If I got you right, I see where the confusion is. I meant Display settings within the VM, not the Display settings of the VM itself. I modified the answer to it fits better – Kristof Tak Nov 4 '14 at 19:53
  • 3
    Instead of tapping TAB 7 times... if you don't see the whole window with all of its buttons, press ALT and click on any non-typing area in the window and you can drag it until you see all the necessary buttons (like Apply and Cancel in this example). This "trick" works for all types of windows and is a general and handy feature in Linux. – Jakke Mar 9 '15 at 13:37
0

Using the .profile with the commands doesn't work and all reverted back to the original setup.

However, if you place these lines into your .bashrc, these will take effect when you fire up a terminal from the original window.

0

Problem : Display / Flicker issue in the VMware Ubuntu installation

I had this problem as well. The Problem is not with Ubuntu installation, its the VM ware settings for a particular image which can create this issue

To fix it I went to settings for VMware Workstation>> select the machine >> right click >> virtual machine settings >>Display >> and disabled the 3D Graphics checkbox.

Just reboot the machine.

After this it was fine.

protected by Community Nov 12 '16 at 13:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.