2

I've recently wanted to try out Ubuntu, but when I enter the desktop, I can't use my keyboard or mouse. My keyboard is a razer blackwidow and my mouse is a razer deathadder. They both work when I'm on Windows and even works on the boot up menu when I have my usb plugged in to run Ubuntu. So it doesn't seem to be my hardware, but it's having trouble detecting my keyboard it seems. Anyone else encountered this problem? (I have my legacy options on in the BIOS)

  • Can you start a terminal window (using another keyboard/mouse) and post the output of the command 'lsusb'? – ph0t0nix Nov 4 '14 at 10:30
  • @ph0t0nix so strangely enough after restarting it like 5 times I was able to get the keyboard and mouse to work. However after I restarted it one more time it stopped working again. It seems like a hit or miss. Anyways I got to run the lsusb and both my razer devices appear BUS 001 Device 004: ID 1532:0037 and the mouse has a different id – user2967685 Nov 4 '14 at 22:35
0

So both are found (as lsusb shows), but don't seem to react (most of the time)... Maybe you can have a look at this page on the ArchLinux Wiki. Over at Phoronix the mouse seems to work without problem, so maybe give it a try without the keyboard connected (if you haven't already done so).

  • okay so I hadn't actually tried to use the mouse without the keyboard yet. However once I started Ubuntu without the keyboard connected it worked like a charm. Once it was reconnected it froze the mouse and the keyboard. So I was curious and tried it the other way around with the mouse disconnected and the keyboard connected. However this time the keyboard worked and once I reconnected the mouse, they both worked. I mean it's a temporary solution, but it's better than no mouse or keyboard haha – user2967685 Nov 5 '14 at 17:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.