3

Similar to this one: How do I get Terminator to start up with my custom layout?

I can get my terminator 0.97 that I installed from ubuntu 14.04 repositories to start up with custom layout properly, if I don't add any custom commands to any terminals. If I add a custom command to any one or more terminals, it will only start up showing the terminals that didn't have any custom commands added to them.

If I add sleep 5;ls as a command to one of four terminals in the layout for example, it will show 4 terminal windows for 5 seconds, and after 5 seconds one of them will disappear.

v@v-MS-7599:~/.config/terminator$ cat config
[global_config]
  enabled_plugins = CustomCommandsMenu, LaunchpadCodeURLHandler, APTURLHandler, LaunchpadBugURLHandler
  suppress_multiple_term_dialog = True
[keybindings]
[profiles]
  [[default]]
    use_system_font = False
    autoclean_groups = False
    background_darkness = 0.91
    scrollback_lines = 2000
    background_type = transparent
    background_image = None
    show_titlebar = False
    font = Monospace 16
  [[new]]
    background_image = None
[layouts]
  [[default]]
    [[[child1]]]
      type = Terminal
      parent = window0
      profile = default
      command = ""
    [[[window0]]]
      type = Window
      parent = ""
  [[test2]]
    [[[child0]]]
      position = 426:218
      type = Window
      order = 0
      parent = ""
      size = 1042, 643
    [[[child1]]]
      position = 321
      type = VPaned
      order = 0
      parent = child0
    [[[child2]]]
      position = 521
      type = HPaned
      order = 0
      parent = child1
    [[[child5]]]
      position = 521
      type = HPaned
      order = 1
      parent = child1
    [[[terminal3]]]
      profile = default
      type = Terminal
      order = 0
      parent = child2
      command = ""
    [[[terminal4]]]
      profile = default
      type = Terminal
      order = 1
      parent = child2
      command = ""
    [[[terminal7]]]
      profile = default
      type = Terminal
      order = 1
      parent = child5
      command = sleep 5; df -h
    [[[terminal6]]]
      profile = new
      type = Terminal
      order = 0
      parent = child5
      command = ""
[plugins]
  [[CustomCommandsMenu]]
    [[[/window 6]]]
      command = /window 6
      enabled = True
      name = /window 6
    [[[/window 7]]]
      command = /window 7
      enabled = True
      name = /window 7
    [[[/window 5]]]
      command = /window 5
      enabled = True
      name = /window 5
    [[[/window next]]]
      command = /window next
      enabled = True
      name = /window next
    [[[/window previous]]]
      command = /window previous
      enabled = True
      name = /window previous
    [[[/window 11]]]
      command = /window 11
      enabled = True
      name = /window 11
    [[[/window 8]]]
      command = /window 8
      enabled = True
      name = /window 8
    [[[/window 9]]]
      command = /window 9
      enabled = True
      name = /window 9
    [[[/window 10]]]
      command = /window 10
      enabled = True
      name = /window 10
    [[[alt+4]]]
      command = /window 4
      enabled = True
      name = alt+4
    [[[/window 12]]]
      command = /window 12
      enabled = True
      name = /window 12
    [[[alt+1]]]
      command = /window 1
      enabled = True
      name = alt+1
    [[[alt+1 ei]]]
      command = "xte 'keydown Alt_L' 'key 1' 'keyup Alt_L'"
      enabled = False
      name = alt+1 ei
    [[[alt+3]]]
      command = /window 3
      enabled = True
      name = alt+3
    [[[alt+2]]]
      command = /window 2
      enabled = True
      name = alt+2

Here http://pastebin.com/UTmhiBGH is a log file when this type of layout is run with -d flag. I'm not sure if I used exactly the above config. It is possible that the command or another similar command was on another terminal when this was run, but the result is always similar.

Also I have placed the LayoutManager.py plugin to the /usr/share/terminator/terminatorlib/plugins but that doesn't seem to work either, giving PluginRegistry::load_plugins: Importing plugin LayoutManager.py failed: invalid syntax (LayoutManager.py, line 5) error. However this custom command problem was there to begin with.

4

When you run a custom command and it exits, the terminal is closed because the command has finished. For your custom commands use a seperate Profile. In that profile in the Command tab you need to change the "When command exits:" combo to "Hold the terminal open".

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.