0

So I have ubuntu 10.04.4 server. I tried two weeks to install zoneminder and configure it with cheap video card. Somehow i managed it last week, but the problem is that I used ethernet. Now I need to use wifi, but my computer doesn't have integrated wifi adapter, so I bought D-Link DWA-137. Problem is that I doesn't know how to set it up. All weekend read about it and tried to set up but without success.

lsusb shows:

Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 15d9L0a4d Dexon
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 2001:3317 D-Link Corp. [hex]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

uname -r:

2.6.32-38-generic-pae

http://www.dlink.lt/en/products/2/1864_b.html -> my wifi USB adapter.

Any help will be appreciated.

  • To whomever voted to close this for being an EOL release, you are wrong. 10.04 Server is supported for 6 more months. That said, you should probably upgrade from 10.04 to at least 12.04 if not 14.04, at this point. – dobey Nov 3 '14 at 21:33
  • I apologize for my mis-step. I have retracted my vote. – chili555 Nov 3 '14 at 22:58
0

Maybe try the basics first. In the top right corner you would see the network icon. Make sure "Enable networking" is selected. Then either edit or create your wireless connection.

Hoping your router has DHCP on you would want ipv4 and ipv6 on automatic. That would leave ethernet. Assuming your hardware is functional and detected you would have the option to select a mac address for it (eth0 if there are no other network devices).

Then if that doesn't do it i would validate the router and the firewall. Assuming you have a network cable i would plug the computer directly to the modem. Repeat the directives above for a cabled connection. Then validate your firewall is not causing trouble by disabling it shortly and just testing a random google search.

The log you posted leads me to think your wi-fi device is detected and working but needs to be configured correctly.

  • With ethernet everything is ok. Problem is only with usb WIFI adapter. I'm using ubuntu server. Once I used Kali and this usb WIFI adapter worked great. – user3901886 Nov 4 '14 at 6:50
  • I would double check that your connection configuration for the wi-fi adapter uses the correct device. If you have a wired adapter and a wifi one, there might be a eth0 and a eth1 to select from. – Mathieu Foucreault Nov 4 '14 at 17:08
0

I recommend strongly that you upgrade this kernel before. Old kernels don't have a good support for USB devices. For this, please see the article below.

How to update kernel to the latest mainline version without any Distro-upgrade?

So, you can try to do a distro-upgrade:

https://askubuntu.com/questions/544898/upgrade-or-change-to-another-distro

Good luck.

  • But won't be there any problems with zoneminder? Because it was very hard for me to configure it and I really don't want to try to do it again :D – user3901886 Nov 4 '14 at 6:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.