10

I'm new to Ubuntu. How can i install wifi driver Ralink RT3290 802.11bgn? And please if you can help me step by step :D Thank you very much!

  • What version of Ubuntu are you running? What version of the kernel? What have you tried so far? – MrTomRod Nov 3 '14 at 19:25
  • i have ubuntu 14.10 and kernel should be latest version, i updateted it. I'm not very good at this. I tried instaling with tutorilas on the internet, but allways something miss. When i try commands make install, it says there are errors – aleksandar Nov 3 '14 at 20:36
  • Aren't the drivers included with Ubuntu? I have a Belkin F7D1101 v2 that uses the same chipset and it has worked fine in Ubuntu 13.10, 14.04. and 14.10. – John Scott Dec 6 '14 at 19:49
  • Highly related and with answers with more “modern” approaches: /questions/756166/rt3290-ralink-driver-in-ubuntu – David Foerster Aug 26 '18 at 15:06
3

NOTE: The links referred to here may no longer operate. They are left in here for historical purposes only.

  • Download the source code of the driver:

    wget http://dl.dropbox.com/u/11876059/DPO_RT3290_LinuxSTA_V2600_20120508.tar.gz
    
  • then extract the file from tar file

    tar -xvf DPO_RT3290_LinuxSTA_V2600_20120508.tar.gz
    
  • after that enter to this dir

    cd ~/DPO_RT3290_LinuxSTA_V2600_20120508
    make    
    # compile the make file
    sudo make install
    # install the make file
    
  • After that activate the wireless driver

    sudo modprobe rt3290sta
    
|improve this answer|||||
  • I have used the script. I have now 16.04 and i got this error when enter the code "make": :85: error: macro "DATE" might prevent reproducible builds [-Werror=date-time] intf(extra, size, "Driver version-%s, %s %s\n", STA_DRIVER_VERSION, DATE, _ ^ /home/ranjit/DPO_RT3290_LinuxSTA_V2600_20120508/os/linux/../../sta/sta_cfg.c:4899:95: error: macro "TIME" might prevent reproducible builds [-Werror=date-time] – Ranjit Apr 29 '16 at 4:11
  • please enter this command "lspci | grep Network" and give me the output @Ranjit – Sudip Das Apr 30 '16 at 7:38
  • 03:00.0 Network controller: MEDIATEK Corp. MT7630e 802.11bgn Wireless Network Adapter – Ranjit Apr 30 '16 at 8:16
  • 1
    link does not work – user1993 Sep 26 '17 at 21:41
  • 1
    @SudipDas it's fine for me now, I solved the issue. I was just pointing out for the validity of the answer – user1993 Oct 2 '17 at 17:33
11

Since Ralink does not patch the driver and the current version does not work, I provided a patched file that you can download and install following this steps

  1. download the patched file from my private Google Drive directory.

  2. open a terminal (Ctrl+Alt+t) and cd into the folder where the file is downloaded, e.g. cd ~/Downloads.

  3. type

    sudo tar -xvf rt3290sta-2.6.0.0.dkms.tar -C /usr/src
    

    to untar the content in a system directory

  4. you should now get a password prompt where you type the sudo password and press Enter.

  5. once the files are all extracted type

    sudo dkms install -m rt3290sta -v 2.6.0.0 --force
    

    to install the driver with dkms

  6. enter sudo password again and ensure that install is completed successfully (it will take some time).

  7. reboot.

  8. Enjoy Wi-Fi with your RT3290 :D

The patch will work up to kernel version v4.14, it breaks on v4.15 onwards due to the change in the kernel timer implementations.

|improve this answer|||||
  • I cannot believe that a private directory on Google Drive is the only source for that file - even with best intentions it can be dangerous to install it. Please provide a link to some official source. – guntbert Dec 6 '14 at 20:23
  • 1
    Yea too bad ralink is not bothered to correct issues and only provides a 2 year old source. I've just removed a few errors from ralink's source. And just downloading the source will surely cause no harm. If you are so skeptical you could go through every line of it. peace – Jim Colaco Dec 6 '14 at 20:29
  • It is not about me. (1) This answer should be useful for a longer time. (2) we certainly don't expect every user to sift through 4.5 MB of source code (even if you patch consists of only 360 or so lines). – guntbert Dec 6 '14 at 20:38
  • 1
    does this driver also provide bluetooth support? – user230910 Sep 18 '16 at 9:08
  • 2
    @ThomasSebastian, yes. You need to 1) remove the patched driver from your kernel: sudo dkms remove rt3290sta/2.6.0.0 --all; 2) remove the patched sources: sudo rm -r /usr/src/rt3290sta-2.6.0.0; 3) load the official driver instead of the patched one: sudo rmmod rt3290sta and sudo modprobe rt2x00lib. DISCLAIMER: not tested. The names might be slightly different. You should be able to reboot after the first two steps to make udev pick the official driver automagically. – SnakE May 3 '17 at 10:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.