4

Have spent a lot of time on this one one but can't find an answer here.

Ubuntu 14.10 clean install. AMD A10-7700K APU with Radeon(TM) R7 Graphics x4.

1) Started with the xserver open-source wrapper and all seemed ok.

2) Installed BOINC but 'No useable GPUs found' in Event Log.

3) Reinstalled BOINC with boinc-amd-opencl but same result, except that it installed AMD graphics fglrx-updates.

4) Downloaded & installed latest Calalyst from AMD and that didn't work at all, wouldn't boot past the mauve screen!

5) Reverted back to setup above. But still no OpenCL for BOINC.

6) In case this was only a 'BOINC' glitch, I went to their website. Found some old stuff about KAVERI support, which didn't solve it.

7) Another program with this problem, darktable, also can't find OpenCL.

A snag is that there doesn't seem to a utility in Ubuntu that tells me clearly whether OpenCL is functional or not.

So conclusion? Ubuntu 14.10 + fglrx 14.201 + AMD A10-7700K = no OpenCL.

True? Hopefully someone out there knows the answer.

  • Does clinfo work? – Ken Sharp Dec 21 '14 at 2:50
  • Ken Sharp: Yes, the one in /usr/bin gives positive return for OpenCL. (Hadn't known I had clinfo!) So I suppose my original question is answered, thanks. Also, I've managed to get OpenCL with boinc... Changed to fglrx-updates from Additional Drivers. Reboot to load, reinstalled boinc, then must always use boot-up manager to stop/start boinc, and OpenCL gpu processing is ok. This didn't work when I posted my original question, but it does now!? Hope this experience helps others. – JohnRH Dec 22 '14 at 9:58
  • Does the following? askubuntu.com/questions/563870/… – Ken Sharp Apr 6 '15 at 19:08
  • Did the above work? – Ken Sharp Jul 4 '15 at 14:00
  • 1
    Ken Sharp: Thanks for continuing to show an interest in this topic. Things have moved on since last year, as I'm now using Ubuntu 15.04 amd64. Boinc version is 7.4.23 including boinc-amd-opencl. I originally tried fglrx-updates but even so boinc didn't find usable gpu, even using the bum trick mentioned above. So I've kind of given up on it, since all works well with the open-source wrapper, except, of course, boinc OpenCL! But boinc does work ok anyway, although without the amd gpu horsepower. But if anyone knows the story with ati/amd, Canonical and Open CL, I'm sure we'd all be grateful! – JohnRH Jul 6 '15 at 8:41
1

Ubuntu dropped support for the old fglrx drivers in 14.04.04 recent patches (they USED to work but Ubuntu changed something that BROKE the support, so you pretty much have to stick with 14.04.03 or earlier).

AMD has NEVER offered any "official" support for OpenCL on the A10 series in their ROCm or AMDGPU-PRO series drivers that DO work with more recent Ubuntu versions, and it appears they plan to NEVER DO SO even though they DO support discrete GPUs that are OLDER than many of the A10 series APUs.

The ROCm stack will SOMETIMES work with the GCN-based A10 APUs (A10-6xxx I think, and definitely the A10-7xxx and later), but that's very hit-or-miss on if it will work or not on a given installation - and is NOT officially supported, so forget getting any SUPPORT out of AMD on such a setup.

Also, if you are going to use fglrx at all, it would be better to use the final release version 14.302 instead of the older .201 version Corresponds to AMD driver version 15.12 (.201 I believe was 15.07 or so).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.