5

With a ThinkPad X61 and Lubuntu 14.04.1, wireless fails to connect but Ethernet is AOK. Multiple SSIDs are seen, in tests at multiple locations, but entering their keys do not enable connection. Open access points also fail. Same key works well on other Thinkpad. MAC address filtering is not on in the gateway (SMC D3GNV). Problem replicated with a different distro booted from flashdrive.

sudo modprobe -r iwlwifi fails with

modprobe: FATAL: Module mac80211 is in use,
modprobe: FATAL: Error running remove command for iwlwifi

sudo modprobe -r iwl4965 

and

sudo modprobe iwl4965

both execute with no errors or messages,

sudo service network-manager restart

wants me to pick SSID and give WPA key. But, that does not fix problem, issue persists.

rfkill returns:

0:hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1:tcacpi_bluetooth_sw:Bluetooth
Soft blocked: no
Hard blocked: no
2:phy0:Wireless LAN
Soft blocked: no
Hard blocked: no

Tried this, rebooted, still fails:

sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-dkms
sudo apt-get install firmware-b43-installer

What's my next step? Other logs linked below.

dmesg
lsmod
syslog
wireless-info.txt (from wireless_script as per https://askubuntu.com/questions/425155/my-wireless-wifi-connection-does-not-work-what-information-is-needed-to-diagnos)

4
  • Your next step is to check the logs to find the cause of the wireless key not working... – Jan Nov 8 '14 at 22:10
  • It is also possible that you have MAC address filtering on the router, might want to check. Also see if you can log into another wifi router or your own with WPA disabled. – Scott Goodgame Nov 12 '14 at 3:21
  • So has this been resolved? It has an accepted answer that makes it look like the question has been correctly answered. If you are looking for another answer I would suggest you unaccept the current answer and explain in your question why the current answer no longer applies to your current situation. – fossfreedom Apr 5 '15 at 20:35
  • Yes, it has been resolved. – K7AAY Apr 8 '15 at 2:11
4
+125

While I might not provide the exact solution to the problem right now, because your question is missing relevant information, here's some things you can do to troubleshoot the problem and perhaps include them into the question, so that other users can help you.

What can you include into your question?

  • Script output from My wireless/WiFi connection does not work. What information is needed to diagnose the issue?
  • Ouput of /var/log/syslog. Try reproducing the problem and note the time when you do it. After you go through the whole process, read the syslog. The recent events are all at the end of file, so you might want to do something like cat /var/log/syslog | tail -n50 to list last 50 lines in that file, but you can change that number as needed.
  • Output of lsmod ( perhaps a driver isn't loading properly );
  • Output of dmesg
  • Output of rfkill list all

Possible issues:

Your ethernet works, but wireless doesn't. So it may well be issue with wireless card ( failiing hardware ), with wireless drivers, or wireless configuration. But until we know what's in your syslog, we probably won't be able to pin-down the issue. There are wireless dongles, which you could use to test whether or not this is wireless card issue, but the better way IMHO would be to boot on a live USB, and see if that works.

5
  • 1
    another thing you can include is rfkill list all – Sergiy Kolodyazhnyy Nov 9 '14 at 8:43
  • 1
    @K7AAY Yup, I've looked through it today. So far I haven't found anything I could identify as possible cause. I'll keep looking, maybe other's will suggest something,too – Sergiy Kolodyazhnyy Apr 5 '15 at 6:53
  • Actually solved by opening Network Manager and manually changing the name of the SSID then entering password on Security tab. Last used when visiting a Hilton, their SSID was in there. Replacing that with my home SSID and entering the password solved it. TY, Serg! – K7AAY Apr 5 '15 at 8:02
  • 1
    So what you're saying is that network manager wasn't taking your config for your network but it took an edited file for Hilton ? So I think the issue could've been solved long ago if you deleted all those configs in /etc/NetworkManager/system-connections/ and tried reconnecting again. It's equivalent of "forget the connection" on android. Try to edit hilton config again, save and delete config file for your network, then try reconnecting to your network. – Sergiy Kolodyazhnyy Apr 5 '15 at 17:00
  • Sure. Had I known to do that. – K7AAY Apr 8 '15 at 2:09
0

The iwlwifi module doesn't work well with all Wifi adapters. Please try this following workaround:

  1. Open the terminal: Ctrl+Alt+t

  2. sudo modprobe -r iwlwifi

  3. sudo modprobe iwlwifi 11n_disable=1

If this solved the problem, please make these changes:

  1. sudo nano /etc/modprobe.d/iwlwifi.conf

  2. add the line: options iwlwifi 11n_disable=1

  3. Save file

  4. Restart the PC.

If not, please let us know.

4
  • you have couple other modules, iwl4965 and iwlegacy . Does removing and reinstalling them has any effect ? – Sergiy Kolodyazhnyy Apr 4 '15 at 17:08
  • From what i see in your dmesg, iwl4965 is the actual module related to your card. Try removing and reinserting that, then restart the network manager for good measure – Sergiy Kolodyazhnyy Apr 4 '15 at 17:25
  • sudo modprobe -r iwl4965 first, if you get no warnings/erros there, do sudo modprobe iwl4965 . I'd do sudo service network-manager restart for good measure as well – Sergiy Kolodyazhnyy Apr 5 '15 at 7:02
  • No warnings or errors on 'sudo modprobe -r iwl4965' nor 'sudo modprobe iwl4965' , and 'sudo service network-manager restart' prompts me to select the SSID and provide password. However, that does not fix anything, issue persists. – K7AAY Apr 5 '15 at 7:41
-1

I would check router settings. First make sure it is set for 11 b/g/n and not 11n only, then check security/encryption settings and have it set to WPA2 only with no WEP or TKIP enabled and allow it to broadcast the SSID as hiding it doesn't make the network more secure. I would also change the channel the router is on to one not being used, here is the list of used channels from the wifi script

Channel occupancy:

9 APs on Frequency:2.412 GHz (Channel 1) 2 APs on Frequency:2.437 GHz (Channel 6) 3 APs on Frequency:2.452 GHz (Channel 9) 4 APs on Frequency:2.462 GHz (Channel 11) 1 APs on Frequency:5.765 GHz (Channel 153)</pre></code>

Then I would go into Network Manager and set the IPv6 settings for your connections to ignore

1
  • This is polishing the cannonballs, Already said this happens at multiple locations, including open WLANs. As to altering the settings, well, that's the Comcast standard setup, which undoubtedly is improvable, but I need to get the PC connecting before I optimize their gateway's configuration. First things first. – K7AAY Apr 5 '15 at 6:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.