1

This question already has an answer here:

I have an external drive that has only my user with read-write (all other groups as read-only).

So when I mount it on another computer, I can't write to it. Yet, even though I am the owner, I can't change permissions to read-write for all, even if I sudo chmod.

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00012a16

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               2  1953525167   976762583    7  HPFS/NTFS/exFAT

marked as duplicate by muru, karel, Charles Green, Mateo, Pandya Nov 3 '14 at 10:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @muru doesn't really solve the issue. changing the mount options only affects it on this computer (on which I already have write permissions), once I mount it on a different computer it's back to read-only. – o_o_o-- Nov 3 '14 at 1:39
  • 1
    @muru nevermind, problem was other computer was Mac and they don't write to NTFS. – o_o_o-- Nov 3 '14 at 1:45
1

Ok, so the problem turned out to be that Macs can't write to NTFS, and the other computer was a Mac.

Solution: don't format drive to NTFS if being shared with a mac.

Not the answer you're looking for? Browse other questions tagged or ask your own question.