After about 10 minutes, Xubuntu 14.04 goes to sleep all by itself. I've set up the shuffle on the music player and it only gets through 3 songs before I have to sign in again. There is no screensaver installed and the power setting for AC is set to never shut down. So, what do I need to do?


8 Answers 8


light-locker is the new screen locking program in Xubuntu 14.04. If you disable light-locker, it should stop locking your screen.

How to disable lightlocker

  1. Go to settings manager > session and startup > application autostart and disable light-locker, which is titled “Screen Locker (Launch screen locker program).”
  2. Reboot your machine and it should stop locking. Alternatively, start up Terminal with Ctrl+Alt+T and run killall light-locker.

Source: Disabling screen lock is not possible

  • 2
    Remark: in Xubuntu 20.04.3 LTS (as of 2021), it is called 'Screensaver' rather than 'light-locker'
    – Maxim
    Sep 4, 2021 at 23:47

There is an easy way: Go to Settings -> Screensaver. In the "Lock Screen" tab, disable the lock screen.


  • 3
    This is the correct solution as of 2021, Xubuntu 20.04.3 LTS. (lightlocker is gone by now.) Alternatively, one can run xfce4-screensaver-preferences and disable the screen lock therein, as I right below. Thank you for the updated answer!
    – Maxim
    Sep 4, 2021 at 23:50

One more solution - start a program below:


and shift the Enable light-Locking slider to the OFF position, then hit Close.

This panel contains two Screensaver sliders as well.

  • 3
    On Xubuntu 20.04, light-locker-settings is not installed by default, but can be installed with sudo apt update && sudo apt install light-locker-settings. May 31, 2021 at 16:41

On my Xubuntu 14.04 install, even when I had Light Locker completely disabled, my screen still blanked after about ten minutes. The solution to my problem was to run the following command:

sudo xset s 0 0

Make sure you run this command from your desktop session and not through an ssh session, or the DISPLAY variable will not be set and this command will not work.

more info: http://ubuntuforums.org/showthread.php?t=1346567

a bug report has been filed: https://bugs.launchpad.net/ubuntu/+source/gnome-screensaver/+bug/498366

even more info: http://www.shallowsky.com/linux/x-screen-blanking.html

  • most annoying thing I've ever dealt with... I'm on Xubutu 16.04, and completely nuked light-locker and gnome-screensaver, and the screen still blanks after 10 minutes while the power manager and greeter settings are set to never blank. I use nvidia xorg drivers and good lord, manually editing xorg.conf finally saved me from this ridiculous issue, as you can't even set this in nvidia-settings.
    – Tcll
    Mar 15, 2019 at 14:11

This worked for me:

sudo mv /etc/xdg/autostart/light-locker.desktop /etc/xdg/autostart/light-locker.desktop.bak

It was based on some info in this bug report: https://bugs.launchpad.net/ubuntu/+source/light-locker/+bug/1287255


As of 2021, (Xubuntu 20.04.3 LTS), it has moved to the 'Screensaver' options.

Thus, one can run $ xfce4-screensaver-preferences and disable the screen lock therein. (One gets the same menu as the one posted by Kaaveh Mohamedi).


You can edit the file at /etc/xdg/autostart/light-locker.desktop and add the line


as documented here. This will disable light-locker globally, which is nice if your family starts complaining that they cannot unlock their desktops. You can copy the file to ~/.config/autostart first to disable it for a specific user only.


Provided more intuitively from the resource in Nacht's answer.

If you use nvidia xorg drivers and have gone as far as to nuke light-locker and gnome-screensaver from your system, and sudo xset s 0 0 doesn't work for you (your screen still blanks),
edit xorg.conf wherever you saved it (typically saved in /etc/X11/) like so:

Section "ServerLayout"


    Option          "BlankTime"     "0"
    Option          "StandbyTime"   "0"
    Option          "SuspendTime"   "0"
    Option          "OffTime"       "0"


save, and reboot

your screen should no longer blank after 10 minutes

  • Please clarify: Did you actually try sudo xset s 0 0 correctly? You said sudo xset 0 0 didn't work, which is not correct and should not work. Please revert your changes to xorg.conf and test the correct command, then rephrase your post if needed. If the command still doesn't work, please mention your version of Xubuntu to help track down the issue.
    – Poikilos
    Jun 9, 2019 at 21:33
  • Yes I did, thank you, I should probably correct that, I wrote this answer from my phone and couldn't view the previous answers while writing it, so I did my best to recall it from memory as I couldn't find the command I tried (probably got overwritten by other terminals I had running)... After finishing I was too stressed and got sidetracked by other stuff in Xubuntu, sorry I never looked back at it sooner.
    – Tcll
    Jun 10, 2019 at 1:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .