1

Up until recently the following solution worked well:

How to disable the keyring for SSH and GPG?

But just a few days ago the solution stopped working for SSH. I now get a GUI prompt for my SSH password and it keeps the key unlocked until I close the terminal session.

I had read some suggestions regarding changing the permissions for the keyring executable so that it can't be executed, and while that works, I won't get a password prompt for wifi networks :P So I opted to reverse that.

Is there anything I can be doing to tackle this particular issue?

2

I had the same problem, and have only just taken the time to fix it.

I fully documented this in my install procedure here:

https://github.com/mattcaron/misc_notes/blob/master/install.xubuntu.14.04

See item 36.

However, the crux of it is twofold:

  1. You need to have the default gnome-keyring-daemon not start all the components, so I create a wrapper such that gnome-keyring-daemon is now gnome-keyring-daemon-wrapped, and the new gnome-keyring-daemon does:

    #!/bin/sh
    exec /usr/bin/gnome-keyring-daemon-wrapped --components=pkcs11,secrets,gpg "$@
    
  2. You also need to edit ~/.config/autostart/gnome-keyring-ssh.desktop and add the following:

    [Desktop Entry]
    X-GNOME-Autostart-enabled=false
    

After that, it seems to behave itself properly.

  • It seems that adding the line X-GNOME-Autostart-enabled=false to the file ~/.config/autostart/gnome-keyring-ssh.desktop is sufficient for me. – Julien Fastré Apr 10 '15 at 20:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.