1

Few days ago I installed Steam, TF2, bumblebee and the newest nvidia drivers. My laptop has an integrated intel gpu and dedicated card (geforce 645m).

I used to launch steam using primusrun steam and just launch TF2 from the steam menu. Everything worked fine and linux used the dedicated gpu for the game giving me stable 100fps.

Without (seemingly) changing anything, today I started having problems: the game won't launch. It doesn't give any errors, just the "Preparing to launch" screen and then it simply disappears. I can still run steam using primus/optirun without problems.

I tried launching steam without primus/optirun and insert primusrun %command% to launch options but it didn't work. The game plays just fine without primus/optirun, but the framerate is quite terrible.

0

Found an answer to my own question here: https://github.com/ValveSoftware/steam-for-linux/issues/3506

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.