66

I am using Ubuntu 14.04, I tried to search for Google Drive on Ubuntu Software Center, but couldnot find it. Searched for answers in Askubuntu but all I found was ways to install Google Drive on Ubuntu 12.04 which didn't worked for me.

Can anyone please give me some ideas?


Update: Don't know why they marked it as duplicate entry, as the link mentioned in question gives answer for Ubuntu 12.04, which as I see is two different things.

  • there isn't a native google drive client for linux yet by google. You might have to try out a 3rd party premium service insync or better wait for google to release one – astrob0t Nov 2 '14 at 10:03
  • 2
    It would be the smartest to also post the links to what did not work. Mind you: @karel answer still works for me (just tested it) – Rinzwind Nov 2 '14 at 10:06
  • change.org/p/… – dhiya Aug 22 '15 at 5:54
  • refer here – Ravan Sep 20 '15 at 6:54
69

Updated 9/15/2015 Due to Google's changing API you might be having problem during installation of Grive. So the site I was referencing have also changed their tutorial for installing Grive2.

You can find new tutorial on this new link: How to install Google Drive Grive2 on Ubuntu

To install Grive2 in Ubuntu, Linux Mint and derivatives by using the main WebUpd8 PPA, use the following commands:

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install grive

Yes, It is true that there isn't a native google drive client for linux yet, so you couldn't get app on Software Center. And ways to install in 12.04 and 14.04 are somewhat different.

Old outdated reference Tutorial How to install Google Drive on Ubuntu 14.04

| improve this answer | |
10

There is no official client of Google Drive for Linux based OSes, you can use grive/grive-tools though.

sudo add-apt-repository ppa:thefanclub/grive-tools
sudo apt-get update
sudo apt-get install grive-tools

Then search for grive in the dash and follow the installers instructions.

| improve this answer | |
  • I get the following error - Sign in with Google temporarily disabled for this app. This app has not been verified yet by Google in order to use Google Sign In. – Sanaulla Jan 22 at 9:30