1

Recently installed Ubuntu 14.04 (Kubuntu, incidentally; but I experience this issue with both gnome-terminal and Konsole).

I have Hebrew selected as a language and as an input method.

When I try to type Hebrew in the terminal, if I'm in bash prompt, nothing shows up. Some of the letters appear bound to actions (e.g. delete the current line. I don't expect unicode to do such stuff). But in the same terminal, if I'm in cat (i.e. just typing without having the shell intercept my keystrokes), the letters show up fine.

Also: In Firefox and Pidgin Hebrew works fine. In Chromium - can't type Hebrew.

Using xxd I see that my input is understood by the terminal to be unicode, which is as I expect.

What might be the problem? Am I supposed to tell bash or the terminal what my encoding is?

1

Turns out that the problem was incorrect setting of my locale. My locale was set to en_IL.UTF-8, which apparently isn't recognized/supported. I changed all entries in /etc/default/locales to be en_US.UTF-8, and then logged out and logged in again - now I can type in Hebrew where previously I couldn't.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.