1

My computer is locking up while I'm using the trackpad. It seems to occur most after I install graphics drivers on a fresh install of ubuntu. It has occured once on a fresh install of 14.10. It also occurs in 14.04 after I install graphic drivers. I can't use ubuntu like this, because it's causing all sorts of problems. Does anyone know a fix?

I'm running an asus republic of gamers g750jm with a gtx860m graphics card in it. I don't believe I'm the only one with this problem and I found a solution that I believe works but it disables my trackpad's two-finger scroll. The page is here: http://www.hackingnotcracking.com/?p=112 does anyone know how to avoid disabling the two finger scroll so I can test and see if this page's suggestion fixes my problem?

UPDATE: I did test that pages solutions they didn't work. I still can't use Ubuntu unless I choose to not install drivers for my gtx860m,... so now I just don't install graphic drivers now.

UPDATE: I am following the instructions laid out here: Ubuntu and ASUS G750JM, GTX860M / Nvidia problems and running into this problem. Any advice or input may help the cause.

Still looking for a solution, I even set a bounty and nothing. I'd open a bug ticket on it but I'm using edgers drivers. When I try to install the nvidia drivers from their website lightdm won't even boot.

  • In order to even begin helping, we're going to need some more information such as computer model, graphics card, touchpad model, etc. Bascially, we need more specifics. – Chuck R Nov 2 '14 at 18:46
  • Okay I added some more info @githlar – Daniel Nov 2 '14 at 20:36
  • 1
    Since this would seem to be a Nouveau-specific problem, I would recommend installing the drivers from Geforce.com (especially since you are using a new NVIDIA card that isn't supported by the Nouveau drivers, no 3D acceleration for Tesla-based cards) and see if that helps to resolve your issue. – Chuck R Nov 2 '14 at 21:13
  • I've already been through that, they never would work I ended up having to solve the issue myself by doing askubuntu.com/questions/519372/… the stuff listed on that page... blacklisting the nouveau drivers isn't really necessary however. But after I do that stuff is when I experience the problem. @githlar – Daniel Nov 2 '14 at 21:34
  • Yep, that is essentially doing the same thing as installing the drivers from the Geforce site (Xorg Edgers has the most updated drivers -- just like the site), except that Bumblebee was installed as well for hybrid Intel HD/Nvidia configurations. – Chuck R Nov 3 '14 at 1:24
0

I was experiencing the same problems on a laptop with GTX 860M, Ubuntu 14.04. I had the mouse cursor freeze (actually it must have been lightdm locking up) due to having the wrong graphics driver active. I had tried with the one from GeForce.com without any luck. Here is how I eventually made it work:

First, make sure drivers from GeForce.com are uninstalled (if you have them installed, run the installation file again with the --uninstall flag).

Then, update your sources, purge any packages with reference to nvidia and bumblebee. Install nvidia-prime and nvidia-340. Run nvidia-xconfig and reboot. Here are the commands:

sudo apt-get update
sudo apt-get purge bumblebee*
sudo apt-get purge nvidia*
sudo apt-get install nvidia-prime
sudo apt-get install nvidia-340
sudo nvidia-xconfig
sudo reboot

Note: if you have trouble using the graphical interface, press [Ctrl]+[Alt]+[F1] and log in on the first cli interface. If needed, enter sudo service lightdm stop to stop the graphical interface before running the above commands.

|improve this answer|||||
  • This is exactly what I've been doing. – Daniel Nov 3 '14 at 20:16
  • Actually this is not exactly what I've been doing, but you see, as soon as I install nvidia-340 the problems start occuring. I was using bumblebee and nvidia-340... having these problems. – Daniel Nov 5 '14 at 5:13
  • I also got problems using bumblebee. Have you tried the combo nvidia-prime and nvidia-340 (or nvidia-current)? – Alasjo Nov 5 '14 at 13:37
  • I just tried it- didn't work either – Daniel Nov 5 '14 at 15:34
0

Turn on trackpad while using keyboard in settings, I found this answer online and so far it has resolved the problem

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.