I installed the latest linux nvidia driver as per this and this. I thought it was running fine but in Additional Drivers it was I'm using the proprietary driver but none is selected in the list. Trying to run steam gives me the error: "OpenGL GLX extension not supported by display". I have nvidia-config but not nvidia-settings. Nvidia x server icon is in settings but if I click it it says something like "you have to close X then run sudo nvidia-xconfig to install this" which I do with sudo system lightdm stop, but it doesn't change anything. glxinfo gives me the same 'everything missing' output as this guy. I then tried sudo apt-get install nvidia-current which looks like it went fine... but now I can't boot into xubuntu - it gets to the point where you'd expect the splashscreen and just sits at a blinking cursor.

Very frustrated. Thought after all the ballache of getting the 340.46 driver installed it was all working but evidently not. Now I can't get into my primary boot, but have my SATA drive 14.04 xubuntu, my primary is my new SSD 14.10 xubuntu. I can't see my SSD from my SATA, it seems, so I don't know how I'd go about (e.g.) deleting xorg.conf or whatever might need to be done. Nightmare. Why is video driver install this complicated?

Does anyone know how I can dig myself out of this hole? Thanks!

p.s. as a generality I assume it's best if I can get the latest nvidia driver working for my card since it'll support the most.. stuff? But does that tend to result in a whirlwind of bugs and thus would I be better doing something else? Cheers.

Edit1: Looks like I should boot into failsafe and restore a safe xorg.conf file? Looking on my 14.04 install, I don't seem to have an xorg.conf file, in /etc/x11 or /usr/x11 or /usr/lib. This might be because I believe I'm running a successful nvidia driver install on this OS?

Edit2: xorg.conf is absent in my secondary OS (which doesn't matter cos it works anyway) but present in the right place in my primary so I booted into root/terminal as per the comment on here then moved/renamed my xorg.conf to see if any of the 3 backups, or no xorg.conf, meant I could boot. They didn't. Logging into my secondary, for some reason the permissions have changed for sudo so not only can I not restart or shutdown, but none of the core features work e.g. gparted. Given that I'd since found that changing xorg.conf on the primary didn't help I guess this was moot but changing the permissions of /usr/bin/sudo, usr/lib/sudo/sudoers.so, /etc/sudoers, /etc/sudoers.d one by one from the secondary OS's recovery root/terminal, only half allowed things to work (would have needed to do the same for /etc/sudoers.d/README and /var/lib/sudo). Gparted could then see the SSD but by then like I say, I've already worked out how to edit stuff in the primary from the recovery root/terminal.

My final, possibly key, startup error message is "init: Error while reading from descriptor: Broken pipe", launchpad bug here. Notwithstanding that my secondary OS permissions are all over the place and massively corrupted, surely there must be a way to 'start from fresh' with the display driver which is assumedly causing all this woe?

Edit3: Tried purging & reinstalling xserver-xorg as per this and then this post, no change. Will look further at the broken pipe error which continues to be displayed after doing the xserver stuff.

Edit4: tried jmiserez's comment on Oli's answer from here, which didn't work. Oli's answer revealed I have nvidia-304, nvidia-331-updates, xserver-xorg-video-nouveau, nvidia-304-updates and nvidia-331 drivers; nvidia-current is already the latest version.

Edit5: trying this solution failed because I don't seem to have networking enabled from the recovery terminal. If I hit "enable networking" from the recovery mode options it lists all the drives, saying clean, then recovering journal, then stops at a blinking cursor and doesn't accept any input. Wonderful.

Edit 6: fixed networking per this. Retried above solution, sudo apt-get install nvidia-current-updates fails with unmet dependencies of nvidia-304-updates. Trying to install that fails with unmet dependencies libcuda1-304-updates, nvidia-opencl-icd-304-updates, and conflicts with xorg-driver-binary. Bashing head against this for a few days now. Best option possibly to purge all nvidia drivers and revert to a clean xorg/nouveau, but I don't know how to do that. Will search around I guess.

Edit7: trying to purge nvidia drivers with this solution fails because python-qgis-common (mapping software) depends libqgis-customwidgets2.7.0 but it is not installed. Tried to install it & that failed: errors were encountered when processing the deb, /usr/bin/dpkg returned an error code (1). Honestly don't see why linux cares that one package dependency is unmet when trying to fix something completely unrelated. Since I have the nouveau driver I'll try force loading that and leave the nvidia drivers alone.

Edit 8: sudo rm /etc/X11/xorg.conf and echo 'nouveau' | sudo tee -a /etc/modules did something at least - I saw the ubuntu 14.10 megabasic 4 dots splash screen then a page of text before the blank screen. It's a list of services getting started, last item is "GNUstep distributed object mapper disabled, see /etc/default/gdomap saned disabled; edit /etc/default/saned". So I guess that's the next lead to follow...

Edit 9: possibly I can access a terminal once I'm at the blank screen section. But I rebooted and it didn't get there again. Rebooted back into recovery terminal and checked xorg.conf was still absent & the nouveau line was still in modules, both true, so not aware of what's changed. Great.

Edit 10: changed nothing and it booted to black this time; didn't get the saned line but did get the GNUstep one. Crtl+Alt+F1/2/3 do nothing. I don't have an F4 key, it broke off. Same problem for this guy, never got an answer, and it looks like he also posted here, where other people have tried the same suggestion I tried and it also bricked their system. Sounds like GDOmap night even be a red herring since it apparently can be turned off...maybe it's not causing a problem it just has an error which doesn't matter, then the boot sequence carries on past it to the display driver & startx and then it goes black. Dead end here, circling back to previous clues, looks like i'll have to debug my mapping program in the terminal. Joy.

TLDR: installing nvidia-current means xubuntu won't boot - stops at blinking text entry bar - possibly implicating broken pipe error. (if this IS the problem) How can I reset my display settings?

  • Can you please update your question and describe your problems? as it is not tl;dr =) – Panther Nov 1 '14 at 20:33
  • fair point! TLDR added. – dez93_2000 Nov 2 '14 at 15:05
  • f***** is not needed. Adding the v was just to stop it being detected. meta.askubuntu.com/questions/11604/… – Tim Nov 2 '14 at 19:24
  • Your video card is not compatible with the nvidia driver. Your options are to use the open source driver, file a bug report with Nvidia, or use a compatible video card. – Panther Nov 2 '14 at 20:23
  • thanks for the info. Not compatible with nvidia-current? I've just looked & failed to find a list of supported cards; I'd be surprised if my card (NVIDIA GeForce 8800 GT) wasn't supported as it's >5 years old now. It's definitely compatible with the later driver I HAD on there, 340.46. Do you know how I select the open source driver without being able to access the system? Thanks – dez93_2000 Nov 2 '14 at 21:16

Manually installing those drivers from package is considered a very bad thing by communities of any repository. And for good reason. Never do it without a good reason.

If I remember right, you could run this driver installer with --uninstall key to remove the driver (mostly). Then, see if it created a file /etc/X11/xorg/conf and remove it, then in /etc/X11/xorg.conf.d remove the file created by this installer but do not remove anything else. Then

sudo apt-get install --reinstall nvidia-current

Should work.

| improve this answer | |
  • Thanks Barafu. Do you mean installing the nvidia-current driver manually is a bad thing, or the 340.46 .run file, or both? So are you suggesting I try "sudo apt-get install nvidia-current --uninstall"? (FYI: I have nvidia-304 & -updates, 331 & -updates, & xserver-xorg-video-nouveau - the later driver has been purged) – dez93_2000 Nov 3 '14 at 22:05
  • Looks like i'm learning that the hard way... though in fairness installing the 340.46 driver, despite being a bit of a pain, didn't cause any problems that I'm aware of. Installing nvidia-current via apt-get was what broke the system... – dez93_2000 Nov 3 '14 at 22:09
  • Edit: not true, "dkms status" reveals I do still have 340.46 on there, I'll try to remove it now. Removed as per: choorucode.com/2013/02/07/… – dez93_2000 Nov 3 '14 at 22:11
  • Edit: simply removing it changed nothing. Will try reinstalling nvidia drivers also. Removed drivers successfully so dkms status returns nothing, but "sudo apt-get install nvidia-current-updates nvidia-settings-updates" fails because of the unmet libqgis dependencies still. Ugh... – dez93_2000 Nov 3 '14 at 22:23
  • 1
    you can use sudo dpkg --remove -force --force-remove-reinstreq package name to remove offending package very forcefully. Just don't mess it even more. Tangled dependencies is a rather big topic because of many possibilities and you already have an extra unknown factor of "What did this installer do?" Of cause, normally nvidia drivers have no such dependency problem. – Barafu Albino Nov 3 '14 at 22:50

I had the same issue /with Ubuntu 14.04/,

Tried everything with nvidia drivers tough... NOTHING only black screen


I changed the newest kernel, downloaded and manually installed the 3.16 fro here http://ubuntuhandbook.org/index.php/2014/08/install-upgrade-linux-kernel-3-16/

After reboot nvidia latest, tested driver 331.38 working

May it helps on xubuntu to change the kernel.

Have fun..

| improve this answer | |
  • thanks. Can't check this now but will have a look at which kernel I have when I'm back at the machine next month. – dez93_2000 Nov 11 '14 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.