3

I tried to install Ubuntu 14.10 (or 14.04) 64-bit on an older Acer laptop (but not a totally weak one, I could run Ubuntu 14.04 on it before). It could install or boot from an USB drive (created via unetbootin). When it's installed, it first complains about not having access to init files and then throws a kernel panic that it could not find init. Nothing can be done with it further, recovery kernelpanicks too.

I tried installing it twice, once using a liveCD iso downloaded via torrent, once using a liveCD iso downloaded from the official website, results were the same.

The error message is:

Failed to execute /init (error -8)
Starting init: /bin/sh exists but couldn't execute it (error -8)
Kernel panic - not syncing: No working init found. Try passing init= option to kernel. See Linux Documentation/init.exe for guidance

Followed by a call stack and memory map which tells me nothing.

6
  • What model of laptop is it, with what hardware? – Wilf Nov 1 '14 at 15:34
  • It's an Acer Aspire 4820 TG, Intel i5, 64-bit, more information can be found here. What is worse, the same problem happened also with Ubuntu 14.04 I tried to install now (several months before, it worked well). Is it possible that it appeared because I installed it on a badly set partition? – Dugi Nov 1 '14 at 19:23
  • There are so many possibilities. UEFI boot ? Run boot repair and report any errors. – Panther Nov 1 '14 at 20:29
  • The laptop never had any UEFI. I reinstalled it three times, do you really think that boot repair might fix it? – Dugi Nov 1 '14 at 21:50
  • First of all the disc structure must be in order. If it isn't, fix it. That said, many computers needs boot parameters to handle special situations differently. If you keep running into the problem, have a look at what other owners of your model have found. – Thorbjørn Ravn Andersen Nov 2 '14 at 22:26
1

After a long research, I eventually found this. According to the thread, there is a bug in the USB installer that prevents 64-bit systems from being installable (on some machines?).

I installed a 32-bit Ubuntu there and the problem didn't appear anymore. This can be an imperfect workaround, but the laptop has just 4 GiB RAM and it doesn't matter much in this case.

1

I experienced this problem too. A 32 bit install of Lubuntu 14.10 on my HP Probook 5310, via a USB stick prepared with UNetbootin, was fine, but when I tried a 64bit install on the same machine, after an apparently straightforward and successful install process, I was left with a black screen on attempting reboot.

I tried various solutions, but without success. I then tried what user347930 suggested, that is to prepare the USB stick in Windows 8 using USB Creator and it worked first time! 64 bit success! Fantastic, Thanks!

0

I had the same problem. The problem came from the fact I installed from an usb key prepared with unetbootin. As soon as I preprared the usb stick with usb creator, everything whent good.

USB creator that has also a problem when a media is introduced in de cd reader. Regards

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.