18

I just upgraded to utopic and the indicator for cpufreq-utils just show two cpu frequency options: Power save and Performance.

Before in trusty:

14.04

Now in utopic:

enter image description here

Regards.

28

If you've got a newer Intel Processor it's because Ubuntu uses a new cpufreq driver called P-State. There are only two governors available for this driver, which are Performance and Powersave.

There are no frequencies listed because you can't actually clock the processor to a specific frequency with newer Core processors. Even if you set it to a specific frequency with the old ACPI cpufreq driver the CPU itself it what sets the frequency on this hardware based on voltage and temperature values.

If you really want to disable this and go back to ACPI cpufeq (older, slower) you need to edit your GRUB config like in this link, only adding intel_pstate=disable instead of intel_pstate=enable.

Run gksu gedit /etc/default/grub

and change the line that says GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_pstate=disable".

Press Ctrl + X and then Y to save.

then run sudo update-grub and reboot the machine to see the change take effect.

  • I'll be using this new driver too. I just tought it was a bug because of the upgrade. Thanks – Jhonnytunes Nov 1 '14 at 3:15
  • 2
    does disabling pstate has any drawbacks? – akabhirav Mar 24 '16 at 10:20
  • Nice "new driver". I hate Windows for adding too many features, but in Linux it's the other extreme! – Rolf Oct 10 '18 at 11:13
11

Ubuntu 14.10 by default uses intel_pstate for frequency control, which has only performance and powersave for governor options. Should you wish to use the acpi frquency control, you will need to boot with the kernel parameter intel_pstate=disable.

To do this, you will need to edit your grub file

In a terminal (press ctrl+alt+t):

cd /etc/default
sudo cp grub grub.backup
sudo nano grub

Find the line beginning with GRUB_CMDLINE_LINUX_DEFAULT

Append the words intel_pstate=disable to this line, before the final quote

Press ctrl+o to write the file, and ctrl+x to exit.

sudo update-grub
sudo reboot

Despite all of this, I have started using intel_pstate to manage my computer, and find it to perform quite well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.