13

I'm trying to send audio over airplay (RAOP) from Ubuntu 14.04. The pulseaudio-module-raop in Ubuntu used to support my 2nd-gen Airport Express, but it no longer appears in my list of pulseaudio sinks. It's been 6 months since I used it, with a lot changing on my system, including a successful upgrade from 12.04 to 14.04. Somewhere along the line I assume something got misconfigured or maybe a prefs file deleted.

I've enabled "Make discoverable Airplay AirTunes" sound devices locally. I've tried deleting the pulseaudio preference files I can find and uninstalling/reinstalling pulseaudio; airplay still doesn't work. I even upgraded to the in-development pulseaudio 5.0 - same results. Pulse seems to work fine except it doesn't "see" my Airplay devices.

As an experiment, I built the experimental RAOP2 version of pulse. It sees my devices and can send audio to them, but it has to be be manually launched and I'd rather be using something from a ppa for updates, etc. I know it used to work so I want to get it (not the experimental raop2 - I already have that working) going again.

Not sure where to look next.

  • You may also have a client.conf in ~/.config/pulse/. System wide configruation is in /etc/pulse/ but previous configs in your HOME will override this. – Takkat Nov 1 '14 at 8:07
  • Thanks. Half the battle seems to be locating all the various config files in all the various places... – Fred Hamilton Nov 3 '14 at 0:25
  • In order to remove the current configuration and restore it to original, you could purge pulseaudo (sudo apt-get purge pulesaudio) and then install it again (sudo apt-get install pulseaudio). The manpages state: "Purge is identical to remove except that packages are removed and purged. Purge meaning that any configuration files are deleted too." – fret Nov 3 '14 at 20:34
  • You mentioned that you troubleshooted a different PA problem. Could you remember some of the things that you altered and add those to your question? And what exactly was that other problem? – Sergiy Kolodyazhnyy Nov 3 '14 at 20:36
  • In order to locate config files, you could try "dpkg -S pulseaudio" (dpkg manpages: "-S Search for a filename from installed packages"). – fret Nov 3 '14 at 20:51
6

From the RAOP2 site here's the guide to get RAOP2 working:

First set up your build system.

sudo apt-get install build-essential paprefs git pulseaudio-module-raop intltool libjack0
sudo apt-get build-dep pulseaudio

Now get the code and build the software

git clone https://github.com/hfujita/pulseaudio-raop2.git
cd pulseaudio-raop2
./autogen.sh
CFLAGS="-ggdb3 -O0" LDFLAGS="-ggdb3" ./configure --prefix=$HOME --enable-x11 --disable-hal-compat
make

Now before you can run your new pulseaudio, you need to make some settings and kill the original pulseaudio.

Run paprefs and check the option to make AirTunes devices available.paprefs dialog

Prevent pulseaudio from starting automatically:

mkdir ~/.pulse
echo "autospawn=no" >> ~/.pulse/client.conf

On Ubuntu 14.10 and earlier you need to copy over the alsa configuration:

cp /usr/share/pulseaudio/alsa-mixer/profile-sets/extra-hdmi.conf src/modules/alsa/mixer/profile-sets/

Now to every time you want to use an AirPlay speaker you need to run your new pulseaudio by doing these two things: kill all existing instances of pulseaudio and run the new one (from the pulseaudio-raop2 directory):

pkill pulseaudio
./src/pulseaudio -n -F src/default.pa -p $(pwd)/src/ --log-time=1 -vvvv 2>&1 | tee pulse.log

This also creates a log file while running, which should help to identify problems.

To stop the RAOP2 version of pulseaudio, press ctrl+c and start the original one with pulseaudio -D

  • Thanks - I already tried that and it works. I mentioned that in my original question but it was sort of buried. I've rewritten the question to more clearly state that I'm trying to fix the original (standard ubuntu, non-raop2) configuration. – Fred Hamilton Nov 8 '14 at 21:52
  • Then you're question is completely different. You want to know how to built packages and create a PPA. The Ubuntu packaging guide is pretty comprehensive. Your original question seemed top be how to get new AirPlay devices working and you mentioned that raop2 only worked once for you. – mniess Nov 10 '14 at 10:45
  • So regarding your original question, my comment it's the solution. If you want pulseaudio 5 packaged, you'll have to get into packaging as pa5 is still beta and will definitely not be included in the next Ubuntu release. Unfortunately the raop2 changes are not compatible anymore with pa4 so a simple patch is not possible. Creating working pa5 packages that completely replace pa4 without regressions is also quite a task. – mniess Nov 10 '14 at 10:51
  • 1
    I guess I'm having some trouble communicating what I want. I don't want pa5 or RAOP2 - I want to get me "stock" pa4 with RAOP(1) working like it did 6 months ago. – Fred Hamilton Nov 10 '14 at 14:27
  • I experimented with RAOP2 and pa5 in case they might provide a solution and/or be useful in debugging (since they show my hardware CAN work). – Fred Hamilton Nov 10 '14 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.