4

I just upgraded to 14.10 from 14.04, and the built-in driver for my ATI Radeon HD 5450 sorta-kinda works okay because I do get a signal on my monitor, but it lacks any kind of acceleration, making the Dash and the menu reallly slow, and even typing this post has a significant keyboard-to-screen lag. What's more, the built-in drivers don't seem to support screen standby, so the monitor stays on forever :-/

I've tried several*) methods of getting proprietary drivers to work, but they all fail the same way: the boot simply ends at tty1 instead of going into the graphical mode.

Is the root cause that no 14.10-compatible driver exist? Or is there a "canonical" method that is proven to work, for ATI, on 14.10? (pun intended...)

As far as I understand the matter by now, the problem seems to be that 14.10 uses X server version 1.16 but all the drivers only mention X server 1.15...

enter image description here

*) Methods I've tried:

  • run sudo apt-get install xserver-xorg-video-ati . see here version is 1.17 – user308564 Nov 1 '14 at 12:32
  • @DuminduMahawela thank you. When should I run that - before or after I install any of the above drivers? Which of my bullets would you recommend? I can't tell the difference. – Torben Gundtofte-Bruun Nov 1 '14 at 13:15
  • It is xserver xorg driver. You dont need to install from the above. just run this in command line. – user308564 Nov 1 '14 at 14:21
  • Thanks again @DuminduMahawela - why not put this as an answer I can accept? I'll try it out and hope for success :-) – Torben Gundtofte-Bruun Nov 1 '14 at 17:46
  • @TorbenGundtofte-Bruun Did the upvoted answer fix your issues? – Dan W Jan 8 '15 at 16:13
1

You can Install Xserver Xorg driver in command line. You dont need to install from the Software & Update.

Just run this in command line

sudo apt-get install xserver-xorg-video-ati

See here at packages.ubuntu.com. Version is 1.17

0

Well things have changed since the release of Omega driver which have support up to version 1.16 of X. Head to AMD website to download the driver.

  • Tried, but didnt work :( – mac Dec 27 '14 at 12:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.