7

When running sudo apt-get update I get 404 errors, I don't have any PPA's.

jeggy@Jeggy-XPS:~$ sudo apt-get update
[sudo] password for jeggy: 
Ign http://dk.archive.ubuntu.com utopic InRelease
Ign http://dk.archive.ubuntu.com utopic-updates InRelease                      
Ign http://dk.archive.ubuntu.com utopic-backports InRelease                    
Hit http://dk.archive.ubuntu.com utopic Release.gpg          
Hit http://dk.archive.ubuntu.com utopic-updates Release.gpg  
Hit http://dk.archive.ubuntu.com utopic-backports Release.gpg
Hit http://dk.archive.ubuntu.com utopic Release              
Hit http://dk.archive.ubuntu.com utopic-updates Release      
Ign http://extras.ubuntu.com utopic InRelease                
Hit http://dk.archive.ubuntu.com utopic-backports Release    
Hit http://extras.ubuntu.com utopic Release.gpg                                
Hit http://extras.ubuntu.com utopic Release                                    
Ign http://security.ubuntu.com utopic-security InRelease              
Get:1 http://security.ubuntu.com utopic-security Release.gpg [933 B]  
Hit http://extras.ubuntu.com utopic/main Sources                               
Get:2 http://dk.archive.ubuntu.com utopic/main Sources [1.046 kB]
Get:3 http://security.ubuntu.com utopic-security Release [59,7 kB]
Hit http://extras.ubuntu.com utopic/main amd64 Packages                        
Hit http://extras.ubuntu.com utopic/main i386 Packages                         
Get:4 http://security.ubuntu.com utopic-security/main Sources [7.232 B]        
Get:5 http://security.ubuntu.com utopic-security/restricted Sources [14 B]     
Get:6 http://security.ubuntu.com utopic-security/universe Sources [14 B]       
Get:7 http://security.ubuntu.com utopic-security/multiverse Sources [14 B]     
Get:8 http://security.ubuntu.com utopic-security/main amd64 Packages [15,0 kB] 
Get:9 http://security.ubuntu.com utopic-security/restricted amd64 Packages [14 B]
Ign http://extras.ubuntu.com utopic/main Translation-en_US                     
Get:10 http://security.ubuntu.com utopic-security/universe amd64 Packages [2.645 B]
Ign http://extras.ubuntu.com utopic/main Translation-en                        
Get:11 http://security.ubuntu.com utopic-security/multiverse amd64 Packages [14 B]
Get:12 http://security.ubuntu.com utopic-security/main i386 Packages [14,6 kB]
Get:13 http://security.ubuntu.com utopic-security/restricted i386 Packages [14 B]
Get:14 http://security.ubuntu.com utopic-security/universe i386 Packages [2.652 B]
Get:15 http://security.ubuntu.com utopic-security/multiverse i386 Packages [14 B]
Hit http://security.ubuntu.com utopic-security/multiverse Translation-en
Hit http://security.ubuntu.com utopic-security/restricted Translation-en
Hit http://security.ubuntu.com utopic-security/main Translation-en   
Hit http://security.ubuntu.com utopic-security/universe Translation-en
Get:16 http://dk.archive.ubuntu.com utopic/multiverse Sources [171 kB]          Get:17 http://dk.archive.ubuntu.com utopic/multiverse amd64 Packages [131 kB]  
Get:18 http://dk.archive.ubuntu.com utopic-updates/main Sources [4.264 kB]
Get:19 http://dk.archive.ubuntu.com utopic-updates/restricted Sources [7.232 B]
Get:20 http://dk.archive.ubuntu.com utopic-updates/universe Sources [14 B]     
Get:21 http://dk.archive.ubuntu.com utopic-updates/multiverse Sources [14 B]   
Get:22 http://dk.archive.ubuntu.com utopic-updates/main amd64 Packages [14 B]  
Get:23 http://dk.archive.ubuntu.com utopic-updates/restricted amd64 Packages [15,0 kB]
Get:24 http://dk.archive.ubuntu.com utopic-updates/universe amd64 Packages [14 B]
Get:25 http://dk.archive.ubuntu.com utopic-updates/multiverse amd64 Packages [2.645 B]
Get:26 http://dk.archive.ubuntu.com utopic-updates/main i386 Packages [14 B]   
Get:27 http://dk.archive.ubuntu.com utopic-updates/restricted i386 Packages [14,6 kB]
Get:28 http://dk.archive.ubuntu.com utopic-updates/universe i386 Packages [14 B]
Get:29 http://dk.archive.ubuntu.com utopic-updates/multiverse i386 Packages [2.652 B]
Get:30 http://dk.archive.ubuntu.com utopic-updates/main Translation-en [14 B]  
Get:31 http://dk.archive.ubuntu.com utopic-updates/multiverse Translation-en [10,0 kB]
Get:32 http://dk.archive.ubuntu.com utopic-updates/restricted Translation-en [14 B]
Get:33 http://dk.archive.ubuntu.com utopic-backports/restricted Sources [14 B] 
Hit http://dk.archive.ubuntu.com utopic-backports/restricted Translation-en    
Hit http://dk.archive.ubuntu.com utopic-backports/universe Translation-en      
Get:34 http://dk.archive.ubuntu.com utopic/restricted Sources [575 B]          
Get:35 http://dk.archive.ubuntu.com utopic/restricted amd64 Packages [18,4 kB] 
Get:36 http://dk.archive.ubuntu.com utopic/universe amd64 Packages [8.000 kB]
Hit http://dk.archive.ubuntu.com utopic-backports/main Sources                 
Hit http://dk.archive.ubuntu.com utopic-backports/universe Sources
Hit http://dk.archive.ubuntu.com utopic-backports/multiverse Sources
Hit http://dk.archive.ubuntu.com utopic-backports/main amd64 Packages
Hit http://dk.archive.ubuntu.com utopic-backports/restricted amd64 Packages
Hit http://dk.archive.ubuntu.com utopic-backports/universe amd64 Packages
Hit http://dk.archive.ubuntu.com utopic-backports/multiverse amd64 Packages
Hit http://dk.archive.ubuntu.com utopic-backports/main i386 Packages
Hit http://dk.archive.ubuntu.com utopic-backports/restricted i386 Packages
Hit http://dk.archive.ubuntu.com utopic-backports/universe i386 Packages
Hit http://dk.archive.ubuntu.com utopic-backports/multiverse i386 Packages
Get:37 http://dk.archive.ubuntu.com utopic/universe Sources [8.345 kB]
Err http://dk.archive.ubuntu.com utopic/main amd64 Packages
  404  Not Found [IP: 194.19.194.51 80]
Err http://dk.archive.ubuntu.com utopic/main i386 Packages
  404  Not Found [IP: 194.19.194.51 80]
Err http://dk.archive.ubuntu.com utopic/restricted i386 Packages
  404  Not Found [IP: 194.19.194.51 80]
Err http://dk.archive.ubuntu.com utopic/universe i386 Packages
  404  Not Found [IP: 194.19.194.51 80]
Err http://dk.archive.ubuntu.com utopic/multiverse i386 Packages
  404  Not Found [IP: 194.19.194.51 80]
Hit http://dk.archive.ubuntu.com utopic/multiverse Translation-en              
Hit http://dk.archive.ubuntu.com utopic/restricted Translation-en
Get:38 http://dk.archive.ubuntu.com utopic/universe Translation-en [19,5 MB]
Get:39 http://dk.archive.ubuntu.com utopic-updates/universe Translation-en [5.776 B]
Get:40 http://dk.archive.ubuntu.com utopic-backports/main Translation-en       
Get:41 http://dk.archive.ubuntu.com utopic-backports/multiverse Translation-en 
Hit http://dk.archive.ubuntu.com utopic/main Translation-en                    
Fetched 32,3 MB in 10min 11s (52,8 kB/s)                                       
W: Failed to fetch http://dk.archive.ubuntu.com/ubuntu/dists/utopic/restricted/source/Sources  Hash Sum mismatch

W: Failed to fetch http://dk.archive.ubuntu.com/ubuntu/dists/utopic/main/binary-amd64/Packages  404  Not Found [IP: 194.19.194.51 80]

W: Failed to fetch http://dk.archive.ubuntu.com/ubuntu/dists/utopic/main/binary-i386/Packages  404  Not Found [IP: 194.19.194.51 80]

W: Failed to fetch http://dk.archive.ubuntu.com/ubuntu/dists/utopic/restricted/binary-i386/Packages  404  Not Found [IP: 194.19.194.51 80]

W: Failed to fetch http://dk.archive.ubuntu.com/ubuntu/dists/utopic/universe/binary-i386/Packages  404  Not Found [IP: 194.19.194.51 80]

W: Failed to fetch http://dk.archive.ubuntu.com/ubuntu/dists/utopic/multiverse/binary-i386/Packages  404  Not Found [IP: 194.19.194.51 80]

W: Failed to fetch http://dk.archive.ubuntu.com/ubuntu/dists/utopic-updates/main/source/Sources  Hash Sum mismatch

W: Failed to fetch http://dk.archive.ubuntu.com/ubuntu/dists/utopic-updates/restricted/source/Sources  Hash Sum mismatch

W: Failed to fetch http://dk.archive.ubuntu.com/ubuntu/dists/utopic-updates/main/binary-amd64/Packages  Hash Sum mismatch

W: Failed to fetch http://dk.archive.ubuntu.com/ubuntu/dists/utopic-updates/restricted/binary-amd64/Packages  Hash Sum mismatch

W: Failed to fetch http://dk.archive.ubuntu.com/ubuntu/dists/utopic-updates/universe/binary-amd64/Packages  Hash Sum mismatch

W: Failed to fetch http://dk.archive.ubuntu.com/ubuntu/dists/utopic-updates/multiverse/binary-amd64/Packages  Hash Sum mismatch

W: Failed to fetch http://dk.archive.ubuntu.com/ubuntu/dists/utopic-updates/main/binary-i386/Packages  Hash Sum mismatch

W: Failed to fetch http://dk.archive.ubuntu.com/ubuntu/dists/utopic-updates/restricted/binary-i386/Packages  Hash Sum mismatch

W: Failed to fetch http://dk.archive.ubuntu.com/ubuntu/dists/utopic-updates/universe/binary-i386/Packages  Hash Sum mismatch

W: Failed to fetch http://dk.archive.ubuntu.com/ubuntu/dists/utopic-updates/multiverse/binary-i386/Packages  Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.
jeggy@Jeggy-XPS:~$ 

Why is this happening, and how to fix it? I am running Ubuntu 14.10

12

This is probably just a race condition while the mirror is updated. It's also possible that you're behind a transparent proxy, maybe even without you knowing it.

Anyway, just wait a couple of hours or overnight, and try again.

If the error persists, you can change to another repository (ex. ...us.archive.ubuntu.com...) or remove previously downloaded index files in /var/lib/apt/lists directory.

  • 3
    this has been going on since I installed 14.10, so I'll try to change to another repository, to do that I'll just change every dk to us using this command sudo gedit /etc/apt/sources.list ? – Jeggy Oct 31 '14 at 20:47
  • Correct - and you can also use a mirror closer to you, perhaps this one. launchpad.net/ubuntu/+mirror/mirror.easyspeedy.com-archive – Jan Oct 31 '14 at 21:00
  • thanks it worked :D Fetched 28,7 MB in 40s (703 kB/s) – Jeggy Oct 31 '14 at 21:22
  • Thank you this also worked for me. BUT I wait 1 day and that fixed;) – αғsнιη Nov 1 '14 at 6:15
  • Thanks, removing downloaded index files helped me immediately :-) – Envek Mar 30 '15 at 16:32
2

I am having the same issue with ru servers.

There is a bug on LaunchPad: https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1394494

Current workaround is to switch to the main server:

enter image description here

0

Either you have a problem with your internet or the server is temporarely down. You can try again some other time.

You can check if you can reach the server with wget:

wget http://dk.archive.ubuntu.com/
  • looks like it's working: paste.ubuntu.com/8765398 – Jeggy Oct 31 '14 at 20:40
  • Maybe you have a problem with your internet connection? 10 Minutes for 32MB seems a very long time... – Merlijn Sebrechts Oct 31 '14 at 20:42
  • I have 25mbps download and 9mbps upload – Jeggy Oct 31 '14 at 20:46
  • that should be more than enough. Have you tried apt-get update again? Do you have the same result? – Merlijn Sebrechts Oct 31 '14 at 20:54
0

UPDATE: if anyone else runs into this issue, I fixed mine by replacing the contents of /etc/apt/sources.list with the following:

deb http://us.archive.ubuntu.com/ubuntu/ vivid main
deb http://us.archive.ubuntu.com/ubuntu/ vivid-updates main

... then run sudo apt-get dist-upgrade.

  • If trying this answer, replace vivid with the codename of your version (output of lsb_release -cs) I have not tested this answer and I do not know whether it is valid, but I do know that Vivid is an unsupported version of Ubuntu and therefore carrying out the instructions in this answer literally as written will fail to help because the repository no longer exists at that location. – Zanna Dec 23 '17 at 21:10
0

I tested US servers as some say and it didn't work. Tested some Dutch servers and didn't work, there are many too ubuntu servers that don't work or are unavailable. Though Ubuntu has a option to seek for a best working and available server. Now it works.

sudo update-manager

and then select tab Ubuntu Software -> Downloaded from -> other -> Select Best server

Now it does work

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.