5

After the upgrade to Ubuntu 14.10, my wireless connection has become unstable.
In every 2 to 3 minutes the network stops working (i.e., I am unable to load any page), even though the Network Manager, shows that I am connected.
So I have to manually disconnect it and connect it again,to make it work again, but then again it only works for another 2-3 minutes.

I'm using a Dell Inspiron 7357, with a Intel Corporation Wireless 7260 (rev 73) card. With Ubuntu 14.04, the adapter worked perfectly.

I don't see neither crashes nor errors in dmesg:

$ dmesg | grep iw
[    3.636727] iwlwifi 0000:02:00.0: irq 62 for MSI/MSI-X
[    3.709654] iwlwifi 0000:02:00.0: loaded firmware version 25.222.9.0 op_mode iwlmvm
[    3.742636] iwlwifi 0000:02:00.0: Detected Intel(R) Wireless N 7260, REV=0x144
[    3.743790] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[    3.744023] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[    3.940407] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    4.863737] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[    4.863967] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S

Of course, I don't have any problem if I select the old 3.13 kernel in Grub (in that case, the firmware version is the .8). Do you have any ideas?

1

1 Answer 1

2

Please try this following workaround:

  1. Open the terminal: Ctrl+Alt+t

  2. sudo modprobe -r iwlwifi

  3. sudo modprobe iwlwifi 11n_disable=1

Case this solved the problem, so...

  1. sudo nano /etc/modprobe.d/iwlwifi.conf
  2. add the line: options iwlwifi 11n_disable=1
  3. Save file
  4. Restart the PC.

Case you have any problem, please comment.

7
  • Would it disable the fastest 802.11n standard? Oct 31, 2014 at 19:04
  • Unfortunately this module works partially in some wireless adapters. You can try update the kernel. Perform uname -aand paste on a comment your kernel version. Oct 31, 2014 at 19:43
  • @MarcosRocha Unfortunately,unless you amend the .conf file, the parameter 11n_disable=1 will go away on reboot.
    – chili555
    Nov 3, 2014 at 14:12
  • sorry, I edited my answer with how to make that permanent. Nov 3, 2014 at 23:04
  • 1
    The option 11n_disable=1 does not work for me. After it, it's impossible to connect again to the network, and I need to reboot. Nov 19, 2014 at 11:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.