I recently upgraded to 14.10 from 14.04 from the software center, 2 days later I changed my Desktop Background from Settings-Displays , I may have updated the system with minor 3 to 10 MB updates from software center after that, I guess. No major changes made.

Now when I try to change the Desktop Background again, it shows the Displays panel is broken.

It is transparent Except for the menu bar and shows "Could Not get Screen Information"

Moreover, even the settings menu frame seems to be broken, the resize icon in the bottom right is missing and I am unable to resize it.

Now how do I change my desktop background and how to fix this issue? Also VLC Audio had issues after 14.10 upgrade , I resolved by reinstalling pulsa drivers, could this also have been due to the Upgrade?

NOTE : I am using the latest version of Binary tested Nvidia Drivers, I had absolutely no issues whatsoever with 14.04

Aren’t releases such as 14.10 supposed to be Stable too even though they are not LTS or am I missing something here?


I had also the same problem in Ubuntu-14.10. I solved it by reinstalling ubuntu-desktop.

type with these commands and see if it is working:

                       sudo apt-get update
                       sudo apt-get install --reinstall ubuntu-desktop
                       sudo apt-get install unity
                       sudo shutdown -r now
  • sorry i just tried it again and it worked , i guess i didn't do it properly the first time around. Feb 22 '15 at 16:53

I don't have a specific answer for that situation but you can usually find out (or get around it) with some troubleshooting:

Most of the upgrade issues are caused by some former settings / config files not being handled gracefully by the newer version of a package. Packages do their best to either be backwards compatible or migrate user's settings so that everything continues to work seamlessly after an upgrade. However this can be hard to test and so a frequent source of bugs.

To confirm this, create a new user and log back in as that user. If the problem is gone you know it's one of your regular user's settings that's doing it.

Alternatively if you're familiar with command line you can test with same user:
- log out + log back in using the console (Ctrl-Alt-F1)
- rename your home folder and create a new one
- log back in and see if you can replicate the issue

If that's the case first backup your home directory then you can either:

  • start putting your config files back (the .files in your home dir, ls -d ~/.??* )
    and see which one is triggering it (do a binary search if there's a lot). It's likely going to be something in .gconf or .config in which case you have to dig deeper.
  • or start from scratch and just import / replicate the settings your care about.
  • hey ,tell me a way to correct without creating a new user and stuff Nov 9 '14 at 12:06
  • 1
    I hope someone comes up with the answer you're looking for, in the meantime it's going to be a lot easier to help you if you take basic troubleshooting steps. Nov 9 '14 at 13:23

It was fixed in an update :) , never mind

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.