5

I frequently use Krusader (Version 2.4.0-beta1 "Migration") file manager. It seems I have done something (mouse drag?) that resulted in a completely empty (white) Krusader window except for its title bar. Restarting the PC does not solve it. Even reinstalling Krusader from the Ubuntu Software Center did not solve it.

I have a relatively fresh clonezilla copy of the Ubuntu system partition; do I have to use it for the purpose? What I must not do with the Krusader to avoid such crashes? May it be caused by a graphics driver?

My system and the display after launching the Krusader.

After entering the password, the KDE Wallet Window disappears. After restarting the PC (after an Update Manager action) only the red icon on the right above the display whitens. Krusader still behaves as described.

The behavior is a matter of the system state of the concerned PC (at the following pictures, running debugger of an other Krusader version at both the PCs is shown.): I have two identical PCs. One of them bleaches Krusader.

$ lspci -v
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
    Subsystem: Hewlett-Packard Company d330 uT
    Flags: bus master, fast devsel, latency 0
    Memory at f8000000 (32-bit, prefetchable) [size=64M]
    Capabilities: <access denied>
    Kernel driver in use: agpgart-intel

00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
    Subsystem: Hewlett-Packard Company D530 sff(dc578av)
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at f0000000 (32-bit, prefetchable) [size=128M]
    Memory at fc400000 (32-bit, non-prefetchable) [size=512K]
    I/O ports at 14e0 [size=8]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: intelfb, i915

00:06.0 System peripheral: Intel Corporation 82865G/PE/P Processor to I/O Memory Interface (rev 02)
    Flags: fast devsel
    Memory at fecf0000 (32-bit, non-prefetchable) [size=4K]

The other does not bleach Krusader, now.

$ lspci -v
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
    Subsystem: Hewlett-Packard Company d330 uT
    Flags: bus master, fast devsel, latency 0
    Memory at f8000000 (32-bit, prefetchable) [size=64M]
    Capabilities: <access denied>
    Kernel driver in use: agpgart-intel

00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
    Subsystem: Hewlett-Packard Company D530 sff(dc578av)
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at f0000000 (32-bit, prefetchable) [size=128M]
    Memory at fc400000 (32-bit, non-prefetchable) [size=512K]
    I/O ports at 24e0 [size=8]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: intelfb, i915

00:06.0 System peripheral: Intel Corporation 82865G/PE/P Processor to I/O Memory Interface (rev 02)
    Flags: fast devsel
    Memory at 40100000 (32-bit, non-prefetchable) [size=4K]

I suspect that the graphics driver is not fully compatible with my system, because both the computers have recently started to show a oscillating picture when waking up from the "suspend" status in Ubuntu (not in Windows).

I tried to install a newer Intel 82865G graphics driver. I have not found it prepared for Ubuntu 12.04.

I upgraded the system of the PC with bleached Krusader to Ubuntu 14.04 and used the intel-linux-graphics-installer_1.0.6-0intel1_i386.deb from Intel's site; it installed a further repository. I understand that it should yield new drivers. I have updated the system with Software Updater. But Krusader remains bleached also after PC restart.

I also tried to use the disk from the other PC. In the Ubuntu 12.04 the Krusader works OK, so the graphics hardware has not failed.

On an older PC of a similar sort, in Ubuntu 12.04 the Krusader works OK:

$ lspci -v
00:00.0 Host bridge: Intel Corporation 82815 815 Chipset Host Bridge and Memory Controller Hub (rev 02)
    Flags: bus master, fast devsel, latency 0
    Capabilities: <access denied>
    Kernel driver in use: agpgart-intel

00:02.0 VGA compatible controller: Intel Corporation 82815 Chipset Graphics Controller (CGC) (rev 02) (prog-if 00 [VGA controller])
    Subsystem: Compaq Computer Corporation Device 001a
    Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 5
    Memory at 44000000 (32-bit, prefetchable) [size=64M]
    Memory at 40500000 (32-bit, non-prefetchable) [size=512K]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 01) (prog-if 00 [Normal decode])
    Flags: bus master, fast devsel, latency 0
    Bus: primary=00, secondary=02, subordinate=02, sec-latency=64
    I/O behind bridge: 00001000-00001fff
    Memory behind bridge: 40000000-404fffff
    Kernel modules: shpchp

This older PC wakes up OK from the "suspend" status, as did both the other PCs some time ago.

Now, I see Krusader bleached on the older PC, too: I caused it by trying to look at the content of a directory while Krusader copied several GiBs from another PC.
The Krusader window remained white after clicking Pause, too. But another instance of Krusader worked OK at the same time. After restarting the older PC the Krusader remains bleached and another Krusader instance called from an other Terminal is bleached, too.

First, I suspected my old hardware and its drivers. As a reply to a comment: Installing pciutils in the Ubuntu 14.04 did not succeed. From the lshw listing, a part about graphics is

*-display
         description: VGA compatible controller
         product: 82865G Integrated Graphics Controller
         vendor: Intel Corporation
         physical id: 2
         bus info: pci@0000:00:02.0
         version: 02
         width: 32 bits
         clock: 33MHz
         capabilities: pm vga_controller bus_master cap_list rom
         configuration: driver=i915 latency=0
         resources: irq:16 memory:f0000000-f7ffffff memory:fc400000-fc47ffff ioport:14e0(size=8)
    *-generic UNCLAIMED
         description: System peripheral
         product: 82865G/PE/P Processor to I/O Memory Interface
         vendor: Intel Corporation
         physical id: 6
         bus info: pci@0000:00:06.0
         version: 02
         width: 32 bits
         clock: 33MHz
         configuration: latency=0
         resources: memory:fecf0000-fecf0fff

To Wilf's idea of Terminal warnings: The bleached Krusader in Ubuntu 14.04 tells

$ krusader
Object::connect: No such signal org::freedesktop::UPower::DeviceAdded(QDBusObjectPath)
Object::connect: No such signal org::freedesktop::UPower::DeviceRemoved(QDBusObjectPath)
krusader(5824)/kdecore (KLibrary) findLibraryInternal: plugins should not have a 'lib' prefix: "libkonsolepart.so"
"/org/freedesktop/UDisks2/block_devices/sdb" lost interfaces: ("org.freedesktop.UDisks2.PartitionTable") 
"/org/freedesktop/UDisks2/block_devices/sdb1" lost interfaces: ("org.freedesktop.UDisks2.Partition", "org.freedesktop.UDisks2.Filesystem", "org.freedesktop.UDisks2.Block") 
"/org/freedesktop/UDisks2/block_devices/sdb" lost interfaces: ("org.freedesktop.UDisks2.Block") 
"/org/freedesktop/UDisks2/drives/SanDisk_SDDR_113_6333011111B1" lost interfaces: ("org.freedesktop.UDisks2.Drive") 
"/org/freedesktop/UDisks2/drives/SanDisk_SDDR_113_6333011111B1" has new interfaces: ("org.freedesktop.UDisks2.Drive") 
"/org/freedesktop/UDisks2/block_devices/sdb" has new interfaces: ("org.freedesktop.UDisks2.Block", "org.freedesktop.UDisks2.PartitionTable") 
"/org/freedesktop/UDisks2/block_devices/sdb1" has new interfaces: ("org.freedesktop.UDisks2.Block", "org.freedesktop.UDisks2.Filesystem", "org.freedesktop.UDisks2.Partition") 

The bleached Krusader in Ubuntu 12.04 of the old PC tells

$ krusader
krusader(2584)/kdecore (KLibrary) findLibraryInternal: plugins should not have a 'lib' prefix: "libkonsolepart.so"

I'm looking for Krusader configuration file(s). Are they in the ~/.kde directory? Which file is it particularly? I'd like to delete the file only before reinstalling Krusader. I am afraid of deleting whole the directory because I have installed other KDE programs. (The KDiff3 is not bleached in the Ubuntu 14.04 of the first PC nor in the Ubuntu 12.04 of the older PC.)

  • Could you add a screenshot of the issue? Also, what desktop environment (GNOME, Unity, KDE, etc) are you using? – Wilf Oct 31 '14 at 2:56
  • @Wilf, I have edited the question to add the information. Thanks! – Tomáš Pečený Oct 31 '14 at 11:16
  • @Wilf, I have edited the question again with pictures from the Qt debugger. I am prepared to co-work with Krusader developers; can you give me a contact? I hesitate to use a general bug announcing procedure, because it may be a matter of my particular old PCs. Thanks! – Tomáš Pečený Nov 1 '14 at 8:55
  • Does the bleaching occur every time you start Krusader? You could try installing and/or using the KDE dekstop, as Krusader may require that to work properly. You can get the contact details from the Krusader site, and you can also try the Krusader forum – Wilf Nov 1 '14 at 13:27
  • Yes, now, the bleaching occurs every time I start Krusader at the first PC. I am glad that I became accustomed to use the system described. Would the KDE desktop installation bring a great change of controlling? – Tomáš Pečený Nov 1 '14 at 13:53
1

I have found that on my machine, hitting Ctrl+F (toggle full screen terminal) in krusader leads to that same completely white krusader window - and it stays that way until you hit Ctrl+F again.

If it happens again: give that a try.

  • I see the bug also with my Dell Optiplex 7010; it is the first crash, I've been using it for 8 months. – Tomáš Pečený Mar 17 '18 at 20:37
1

For one of my PCs, that now uses the Nvidia graphics card, the bleached Krusader starts to operate normally after setting all the the Krusader user settings to defaults.

A good idea is to note everything that has been set. Then run the Krusader Konfigurator and for all items (Panel, General, ...) click the Default button and confirm the action.

(At the other PC I have not seen the bleached state since I have guessed the solution, but I believe that the treatment also helps. By many attempts, I found out that the bug has something to do with settings. The whole problem may be caused by my using old CPUs not certified for Ubuntu.)

For a yet older Pentium III HP Compaq using its integrated graphics only, the treatment helps, too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.